Ignore search results page

I have page rule set as follows:

https://mysite/search-results/

Cache level No query string

I would expect my search results page to not be cached, typical request would be

/search-results/?q=business

However its being cached. I have also tried setting cache level to by pass but its still being cached. FYI i am on free plan will be going pro soon.

Am I missing something obvious?

have u checked the priority of this new rule?

It has priority of 1 so its first in list of page rules. FYI the 2nd rule is set to everything on the site

and you cleared cloudflare cache and browser cache as well?

Yup but will try again, with regards to browser cache i used chrome disable cache option in chrome inspector

So clearing cache inc browser, when i first do search i get header

cf-cache-status:

EXPIRED

Then HIT

So its still caching

can you please share the page rule screenshot and domain?

I can share screen shot but not domain as its not live yet and client will not be happy if i share it. See attached image, I have rubbed out actual url just kept the path part.

Can you change two thing in this rule and try
put a * after /search-result/*
and use cache level bypass rather than query string.

1 Like

Ok that works, although i am sure i already tried this. One thing though this time round after the change I purged the cache then hit the site again.

Many thanks for your help