If I try to connect my own sites I get 403 Forbidden openresty

ok, there is a lot of similar topics but… Cloudflare is blocking my own IP and I can’t find any setting or create any rule that allows me to bypass this problem.

any idea? tks in advance and happy new year

Can you share the name of the domain or perhaps a screenshot of the issue?

if I try to access usina.com, which I own, I get the attached screen.

if I try to access via another network it works fine, which seems to be a sign that my public IP is blocked

That really seems as if your own IP address is blocked (assuming you rewrite addresses).

The Cloudflare IPs seem to be fine -> sitemeer.com/#https://usina.com/

Check your server logs, they should give you a hint what is blocked and then you can search your server configuration for that.

it looks like my requests are not reaching my servers, I already checked with my hosting provider

Try clearing your local DNS cache, browser cache and check your hosts file for any entries for your domain.

1 Like

For starters, @MarkMeyer made a good point and you should check that. If you resolve to the wrong IP address we wouldnt need to debug any further.

Can you also post the output of https://usina.com/cdn-cgi/trace?

no matter what computer I use on my network the results are the same… my router is Google Mesh device.

No matter what i do, it works for me.

Follow @sandro 's advice:

Additionally, open a command line and run

nslookup usina.com
nslookup usina.com
nslookup usina.com

And post all the results here.

BTW: is it possible that there’s a .htaccess in place blocking your own IP?

folks, I gave up and simply restarted my fiber optics modem, got a fresh IP and then everything is working fine again. I guess I will never know what was going on, but thank you so much for your friendly support!
best regards and happy new year!

Under these circumstances we most likely do. It will have been the very issue @MarkMeyer addressed.

You shouldn’t be seeing this error at all. It happens very rarely–the signature white Nginx error page with openresty at the bottom. As far as I can tell, it’s not related to any options an end user can set or a misconfiguration. It’s usually temporary, and changing your IP address can help, but if it happens again and doesn’t go away, check cloudflarestatus.com. If everything is green in your region, open a support ticket; if possible, provide the value from the CF-Ray header for one of your requests, or the ip and colo values from http://usina.com/cdn-cgi/trace.

thank you!

This topic was automatically closed after 30 days. New replies are no longer allowed.