IDN stopped working


#1

Seems that a domain I manage doesn’t work any more. As far as I can see the setup is correct , but cloudflare still complain and the domain isn’t working . What should I do?


#2

As the warning message points out the root domain does not resolve.

I agree the setup does appear as if it was correct, but my assumption is the control panel has some issue with the IDN. Instead of the root domain it is vävtak.se.vävtak.se which actually resolves.

Try removing that A record and add one for @ or alternatively for xn--vvtak-gra.se. If neither fixes your issue I’d open a support ticket.


#3

Thanks! Removing and adding back ‘@’ helped.

However, all files are as cache-miss according to https://www.webconfs.com/http-header-check.php

I did try to add a cache everything rule with no success.


#4

Your first page rule might override the cache everything directive.


#5

Thanks. The rule was disabled. I removed it but the issue is exactlye the same.

If I add the xn–vvtak-gra.se in the page rules section, it translates it to the idn equivalent vävtak.se.

What I don’t get is the “cache-control: max-age=0” response. This is not set on the origin server.

EDIT: I added two settings, but they did not help: Edge Cache TTL: 4 hours, Browser Cache TTL: 4 hours. I still get the “cache-control: maxe-age=0” response from CF.


#6

Not sure if the IDN might be an issue again.

Remove both rules and create one with exactly the following parameters

Also, verify your server is not sending any caching headers which might disable caching.


#7

Thanks. I will double check the server config. Perhaps there is a mistake there. As far as I remember I there should be pretty long cache time …

It seems as my apache configuration wasn’t working as I expected.

I had “ExpiresByType text/html M604800” which did not work. I removed it and used a and “ExpiresDefault A6046800”. Perhaps its the “M” time that was wrong. A is better in my situation.

Thanks again.


closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.