Idempotency_key not working?

I have appended the itempotency_key value to the formData before posting to https://challenges.cloudflare.com/turnstile/v0/siteverify however, I still get the error timeout-or-duplicate. Even with the itempotency_key hardcoded, it still throws the error. Not sure if I’m doing something incorrectly here.

    formData.append('secret', cloudflareKey);
    formData.append('response', token);
    formData.append('idempotency_key', 1);
3 Likes

Is ‘1’ a valid UUID?

1 is not a valid uuid but there was no validation error, I have tried with uuid as well such as 17753f4c-b0cc-4cc0-97b2-1c7a87ccc300.

2 Likes

I’m seeing the same thing with a valid UUID.

1 Like

i’m getting same problem with both UUID v1/v4. When can we expect fix or what i’m doing wrong with key?

Hello! We looked into this issue and found a small bug. The fix will go out in the next few weeks (early-mid October). In the meantime, we isolated this issue to only form data requests. Sending a JSON request should work as expected.

2 Likes

Hi @amacovei, thanks for looking into this. Do you have any updates on this bug?