Ideas about log in issue

Did he mean he switched to grey cloud as that would disable cf ssl though?

I think they meant that it was :grey: and they switched to :orange: to enable SSL…

hey i’m here what info do you guys need to be able to help?

Hi @rawcyanide, welcome.

I guess the redirect question from @cbrandt is open. I don’t see any page rules. Yes on :logodrop: change @domjh.

i was told to add some page rules by some one else in the 000webhost forum and that just made my site not work

2 Likes

Here are some options in this tip, Community Tip - Fixing ERR TOO MANY REDIRECTS, was it the always use https page rule you implemented?

this is what i was told to do

This rule can safely be ruled out as the cause for your sign-in form issue.

Do you have any rules at the server level, like any .htaccess directives re: redirects?

2 Likes

i don’t think so

Still on-going issue.

The script works fine over HTTP & also HTTPS just not Cloudflare?

It is really weird the script will function fine over HTTPS:// on the free subdomain.

When logging in there is no errors in Console and the correct error message is displayed if you try to login with wrong password / fake user / reset password error message appears correctly.

When running on Cloudflare

With HTTPS in the config file you get infinite redirects (can we fix this?)

Or if you use HTTP in the config file you get

The site loads without the redirects error and has no issues apart… from obviously logging in/doing any functions to get in.

You get this annoying error

& the mixed content console error

Is there a simple way to fix the redirects error or is this because it isn’t a full certificate and using flexible? :slight_smile:

I don’t think so, as Flexible does not require HTTPS at the origin.

I just tried some test user/pass and it did return the same message, even though the site is now on Cloudflare, as there are CF- headers.

1 Like

Thanks for the reply.

Weird you get that, I don’t see any message currently.

I think it is a script issue @rawcyanide

1 Like

oh i guess it could be but i don’t know why it works with 000webhost and when i used to have paid hosting

wait wtf it works now for some reason, i can log in and still keep the ssl certificate!

1 Like

Talk to @ckhawand he was going to look at your scripts code.

okay do i just private message him on webhost?

Yeah or via Discord :slight_smile:

alright but what did you do? what was the problem lol

I haven’t the foggiest I only checked your CF and then handed it over to him to deal with.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.