I want to add my business email in thunderbird

I want to add my business email in thunderbird. but they need username or password.
how can i login it?
anyone can help me in this?

You would need to consult the instructions provided by your mailbox provider. Cloudflare does not have an email offering that includes mailboxes.

Hi,
i added dns for email .
but dns showing error.
don’t know how fix it.

Can you provide more information?

What is the error? Where do you see the error?

Are any of your email related records :orange:? They need to be :grey: for email protocols like SMTP, IMAP, or POP to work.

I added dns server
Mail. site. com
But it’s showing dns error : _dc-mx.b6b1dbbed53c.emilymahr. com

I’m not sure what you have done already, but it is definitely not a valid DNS setup.

You have 4 MX records for your domain. 2 point to the host name you referenced in your error. That host name resolves to a non-routable IP address. The other 2 point to hostnames that have no A or AAAA records.

I see that you have a hostname of mail that is :orange: proxied and not referenced in your MX.

None of those records do what you want. From what I am seeing in Cloudflare support search results for _dc-mx it appears that MX records in that format appear when you point your MX to a :orange: proxied hostname.

I suggest that you remove all of your MX records and take time to plot out the desired mail flow, and then create only the records necessary to provide that outcome.

If your domain is example.com and you are running your inbound mail server at mail.example.com on IP 192.0.2.25, you would need the following records:

@          MX     mail.example.com
mail       A         192.0.2.25

In the above example, it is important that the A record for mail is set to :grey: DNS Only.

Hi,
Yes I want to login email which added in Cloudflare.
For that I want dns.
And I removed all dns and added dns as u said.
Can u check that it’s fine now?

It’s showing error yet.
Can u solve it by yourself please?

The A record of your MX hostname is still set to :orange: proxied. You need to toggle that setting to :grey: DNS only.

If you want to use Cloudflare Email Routing, that is not what I am describing, and it also is not something that you can login to. Cloudflare Email Routing is an email forwarding service and it requires that you have a mailbox on another system that you will be using to read and send your email.

Are you trying to set up Cloudflare Email Routing or are you trying to get email working with email from your hosting provider?

I am using only email router.
Simply i creat an email on Cloudflare. And this email I want to login in my mobile , for login I have dns details.
Don’t know how I login my email on another platform.

Like I need imap or SMTP server for receiving and sending email

You don’t get that from Cloudflare. It is not a service they provide.

Cloudflare Email Routing is not an email service with mailboxes. It is only a forwarding service. You cannot login to your mailbox on Cloudflare.

Here is how Cloudflare email routing works:

  1. You set up Cloudflare Email Routing on your domain example.com.
  2. I send email to you at [email protected].
  3. Cloudflare Email Routing Forwards that email to your mailbox [email protected].
  4. You login to your mailbox on SomeFreeMail and read it.

If you do not have a mailbox somewhere, you cannot use Cloudflare Email Routing.

you didn’t understand me. I have mailbox. I don’t want to login mailbox in Cloudflare. I am saying how I login my email in my mailbox??
My mailbox need dns records for it.
Imap or SMTP server for login.
Hope you can understand.

You got my point?

No, I don’t.

If you have your own mailserver and simply need hostnames to put in your account in Thunderbird, just create the relevant A records pointed at the server IP address and make sure that they are :grey: DNS Only.

I covered that already in my second reply.

Until you fix the problem with your MX record and the proxied A record for the MX target, you are not going to receive any email at that domain anyway.

Yeah I want hostnames .
Can you tell me again that how I can make relevant records?
Which records I have to make?
I made mail.example .com but it’s showing an error.

It is showing an error because you have it set to :orange: proxied. Set it to :grey: DNS Only already.

Once you do that, you can likely use it in your Thunderbird account settings for IMAP and SMTP, but until you edit the A record in Cloudflare to set it to :grey: it will not work for email!

I changed.
Check it that it is fine now?

Your MX record is now correct.

The IP in your A record for mail is pointed to is not valid. 192.0.2.25 is the example IP address I used earlier. I used it because it is from a network specifically reserved for use in documentation and will not route. You need to replace it with the real IP of your mail server. This address is assigned by the hosting company that operates your mail server. You will need to check with them if you do not know it.