I switch my web to cloud flare server i face internal server error 500

hi i am using Cloudflare but i face internal server error when i try to log in to wordpress dashboard …olease help me…when i by pass Cloudflare cashe and on development mood… then i have face no error when i login

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing na issue with some of the known 5xx error.

May I ask you to share a screenshot of this error? :thinking:
Is your WordPress configured to work over HTTPS?

Before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS (maybe you have to renew your SSL certificate at your origin host/server, or AutoSSL at cPanel).
  4. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

yes my site is https

May I ask have you tried enabling the WordPress debug mode to troubleshoot for any issues, if so? :thinking:

Quick tip: Tune-up your PHP values a bit at your server/hosting provider/cPanel if you can:

memory_limit = 256M
max_execution_time = 300
max_input_time = 1000
max_input_vars = 5000 or 7000
post_max_size = 64M
upload_max_filesize = 32M

Your SSL/TLS encryption mode is Full

WordPress debug mode i check no error show

831564ea-7cad-46ef-b52a-32ca818b75df

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.