I set up website custom domain on pages. Then my wordpress's some menu shows unexpected error occured. How to fix it?

My website’s all menu has worked fine when it deployed subdomain. But it has occured when i am setting up custom domain, it shows me wordpress’s some menu “unexpected error occured”. How can i fix it? help guyss

May I ask os this somehow related to some plugin for WordPress or?

Have you re-checked your Permalink Structure options, if you changed from sub.domain.com to domain.com?

May I ask where does this appear? At the dashboard, log file, developer console of a Web browser, or?

Have you tried enabling the WordPress debugging at the origin host / server?

1 Like

Thanks for attention @fritex . It does appear dashboard of my website. How can i check permalink structure :sweat_smile:

1 Like

Well, I would suggest to run your WordPress website in a debug mode just in case.

I believe you can find them under the Settings → Permalink:

NOTE: Either in case you do not change anything, just hit the button “Save”.

P.S. Maybe you would need to install the plugin like Better Search and Replace, to find out the links to your sub.domain.com and therefore replace sub.domain.com with domain.com in your database using it.

And possible redirection issue or something more could be in case you are using a non-www and put www there, or vice-versa. Please, re-check this under the Settings too for “Home URL” and “Blog URL” field.

I am afraid this is not related to Cloudflare, or, somehow it could be if the server returned some timeout or was busy and Cloudflare request has timed out after 100s, so the WordPress dashboard thrown that error - just guessing the scenarios.

Rather, would be a 524 error, if so:

1 Like


that error appear on my web browser when i click submenu of my deployed website on pages. In other word submenu’s api connect into my wordpress when it gives me like “unexpected error occured”. Do you understand? apologize my english :pray:

Using NextJS or this is rather due to some WordPress plugin using it?

I am afraid redirect/rewrite path is configured wrong at your Apache/cPanel or in general vhost file for your domain, at least as it seems to me.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.