I set the domain SSL is no working……


#1

I set the domain SSL is no working……


#2

Domain? Error?


#3

I can load with http. I have selected the ‘Flexible’ option for SSL under the crypto tab. I did previously have a Let’s Encrypt SSL certificate on this domain. Is that where my issues are coming from? Even in a browser I have never used, the HTTPS isn’t working.


#4

I can’t load with https


#5

Can you share the domain name?


#6

supssr.com


#7

Just enable the Always use HTTPS setting in the crypto tab of your Cloudflare dashboard.


#8

If you have an SSL cert on your server or can install one, you should and ideally choose the full or full strict options as they are far more secure.


#9

“as they are the only secure options” :smile:

SCNR


#10

I enable the Always use HTTPS,but is no working…


#11

Works for me. Try clearing your cache.


#12

Your site appears to load just fine on HTTPS.

But, as @domjh already mentioned, please please switch to Full and install a certificate on your server. Otherwise your page is not secure either.


#13

https://supssr.com ???


#14

What about it? Your questions appear to have been answered above.


#15

Which other site could I be possibly referring to in this context? :wink:


#16

err SSL version or cipher mismatch


#17

I am prompted err SSL version or cipher mismatch when I visit https://supssr.com


#18

You are most likely contacting the wrong server. Check what your host resolve to for you.


closed #19

This topic was automatically closed after 30 days. New replies are no longer allowed.