I see this error ERR_NAME_NOT_RESOLVED every time I visit my site

Hi,

I added a secondary domain of mine., I have setup a redirect of the same to my main domain. All through cloudflare.

So when ever I visit my secondary domain, it simply gives me this “ERR_NAME_NOT_RESOLVED”

I have tried on multiple devices, multiple connections etc. Unable to sort this out from at least 2 weeks, waiting to hear from the support too - they had shared an help article which did not help me sort out the issue.

It will be great if you can help sort out this issue. Thank you

What’s the secondary domain name?

This is the secondary domain

I have also attached the screenshot of the browser error

shreshti has a DNS record for ‘www’, but not for shreshti.com

If you want shreshti to redirect to some other domain, you can do this:

1 Like

Thank you very much, I had actually followed the same article a few weeks ago to setup the page rules.

After you noted, I actually tried www dot shreshti dot com, this seems to redirect perfectly to my primary domain.

But if directly try visiting shreshti dot com, it doesn’t seem to work. Please view my settings here

People don’t tend to use “www” anymore - so when someone enters shreshti dot com > I want them to be redirected to my primary domain.

Thanks for your help

You only need one Page Rule. If you model it after Step 2 in the tutorial, everything will redirect. The $2 at the end would be unwanted if you are not forwarding the path as well.

1 Like

What kind of sorcery is this? I just removed all page rules except one and implemented your suggestion. It worked in an instant.

I was waiting for a solution since 2+ weeks.

Thank you so much @sdayman

1 Like

Oh wait, it does NOT seem to be working now.

Also, can I remove the record with a dummy IP? What’s the alternative?

It’s working for me. Don’t change any of your records.

1 Like

Great, works now. Not sure but happy that it is working now.

Also, can I remove the record with dummy IP now that I have setup the page rule in the right way?

No, you need that. It’s set to :orange:, and that triggers the Page Rule forwarder.

1 Like

Ok great.

So this particular record wouldn’t affect any other records or subdomains which I might add. Is that correct?

No, it’s very specific to that one hostname.

1 Like

Brilliant, thank you so much for assisting through out.

1 Like

Hi,

I have setup a subdomain with an A record “join” under shreshti dot com - when I visit, it simply redirects me to adithyashreshti dot com. What am I missing here? Is it because of the page rules? @sdayman