I redirected a domain to a site under Cloudflare and the redirect doesn't work

Hi guys,

I had a website that I decided to stop maintaining and to redirect all the existing urls to a specific url on another website using 301. The target url (I’ll call it “domain.com”) is covered by Cloudflare and the redirected urls are not covered by Cloudflare.

The redirected site (toptapeti.com) is managed by Namecheap and it was redirected through DNS settings, following the instructions provided by their live chat support. They say that the redirect is working fine for them and correctly, but the target page doesn’t load, because Cloudflare is blocking the requests.

However, when trying to load any url of the redirected site, none of them redirects. I get: " This site can’t be reached. toptapeti.com took too long to respond."

I did the redirection a week ago. I tried on different devices, different browsers, incognito mode, different networks, but it doesn’t work.

I have some WAF custom rules on the target domain and I assume that this one is probably causing the issue:

I have a “skip all rules” rule on the first position as well:

cloudflare2

I added the redirected url as a “referrer equals”, also tried “referrer contains”, but without success.

Any help is greatly appreciated!

Thanks!

From https, the site you are redirecting from (on Namecheap) times out. From http, the redirect takes place ok…

curl -I https://toptapeti.com
(no response)

curl -I http://toptapeti.com
HTTP/1.1 302 Found
Date: Tue, 02 Apr 2024 07:58:57 GMT
Connection: keep-alive
Location: https://www.grandecor.bg/%D0%BC%D0%B0%D0%B3%D0%B0%D0%B7%D0%B8%D0%BD-%D0%BF%D1%80%D0%BE%D0%B4%D1%83%D0%BA%D1%82%D0%B8/%D1%84%D0%BE%D1%82%D0%BE%D1%82%D0%B0%D0%BF%D0%B5%D1%82%D0%B8/
X-Served-By: Namecheap URL Forward
Server: namecheap-nginx

You’ll need to check on the Namecheap end why HTTP doesn’t work.

1 Like

Hi sjr,

thanks for your advice!
I contacted Namecheap again and they confirmed once again that the issue is not on their side. They say the DNS configuration is properly done on their side in order to redirect all urls to the desired landing page. The issue should be on the other side - Cloudflare.

DNS is configured, but https isn’t.

Only http://toptapeti.com redirects as I showed above. That does redirect from Namecheap, to your Cloudflare site, which then loads. It it doesn’t load for them, then you may have some Cloudflare rules that may block them. It loads ok for me.

The redirect from https://toptapeti.com does not work, it just times out (port 443 appears to be closed). Try it yourself.

Their guide for doing an HTTPS redirect is here…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.