I need your help!

When creating a rule where the IP address can bypass the condition, a problem occurred: the server periodically shuts down (approximately every hour) and some requests do not work

It is not clear what you mean by “shuts down” but that rule most certainly won’t make your server “shut down”. That rule simply skips the two selected security features for that IP address.

If your server does not respond any more that will be a local issue and you need to check your server logs.

1 Like

The rule set above in Firewall does not work correctly, it blocks and returns an error 200

A 200 is not an error. It’s actually a success code (OK).

How does it block? And a 200 is not an error but actually what you should expect. Post a screenshot.

Again, what do your server logs say?

Except for one 404 there isn’t a single error in that log.

I am not sure what the issue is supposed to be.

1 Like

Also, you are not rewriting IP addresses. You should check out https://support.cloudflare.com/hc/en-us/articles/360029696071-Restoring-original-visitor-IPs-Option-2-Installing-mod-remoteip-with-Apache

Initially, everything works correctly, when a user is authorized, a post request is sent via the launcher to the site (API key), but after a certain time (about an hour or a little more), access is denied

if ($_SERVER[‘REMOTE_ADDR’] != $config[‘auth_ip’] || $data[‘apiKey’] != $config[‘access_key’]) json_return_error(“Отказано в доступе”);

It is most likely that IP address check then. As I mentioned you need to rewrite the IP addresses on a server level, otherwise that will never really work.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.