I need to cache images but i found cf-cache-status: REVALIDATED

As a result of looking at the requests of the images I use,

cf-cache-status: REVALIDATED.

I need to cache all of the images including png, and gif

How do I change my setting?

I am currently using Node.js and my website url is

Revalidated means edge chache expired, however image was not pulled from origin since Orin responded with 304 not modified, you can increase edge cache ttl in page rules .

Regards
Miroslaw Pabian


Am I doing right?


I still see revalidated :frowning:

Hi Interesting,

Did you try to refresh couple of times ? first time may be Revalideted due to expiry but next one should be hit.

I have tested that and it is cf-cache-status: HIT

curl https://sigbtc.pro/assets/img/white/kakao4.png -ivk

  • Trying 104.26.7.80…
  • TCP_NODELAY set
  • Expire in 149998 ms for 3 (transfer 0x55e6bcba0f90)
  • Expire in 200 ms for 4 (transfer 0x55e6bcba0f90)
  • Connected to sigbtc.pro (104.26.7.80) port 443 (#0)
  • ALPN, offering h2
  • ALPN, offering http/1.1
  • successfully set certificate verify locations:
  • CAfile: none
    CApath: /etc/ssl/certs
  • TLSv1.3 (OUT), TLS handshake, Client hello (1):
  • TLSv1.3 (IN), TLS handshake, Server hello (2):
  • TLSv1.3 (IN), TLS handshake, Encrypted Extensions (8):
  • TLSv1.3 (IN), TLS handshake, Certificate (11):
  • TLSv1.3 (IN), TLS handshake, CERT verify (15):
  • TLSv1.3 (IN), TLS handshake, Finished (20):
  • TLSv1.3 (OUT), TLS change cipher, Change cipher spec (1):
  • TLSv1.3 (OUT), TLS handshake, Finished (20):
  • SSL connection using TLSv1.3 / TLS_AES_256_GCM_SHA384
  • ALPN, server accepted to use h2
  • Server certificate:
  • subject: CN=*.sigbtc.pro
  • start date: Jun 15 18:52:53 2021 GMT
  • expire date: Sep 13 18:52:52 2021 GMT
  • issuer: C=US; O=Let’s Encrypt; CN=R3
  • SSL certificate verify ok.
  • Using HTTP2, server supports multi-use
  • Connection state changed (HTTP/2 confirmed)
  • Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
  • Using Stream ID: 1 (easy handle 0x55e6bcba0f90)

GET /assets/img/white/kakao4.png HTTP/2
Host: sigbtc.pro
User-Agent: curl/7.64.0
Accept: /

  • TLSv1.3 (IN), TLS handshake, Newsession Ticket (4):
  • TLSv1.3 (IN), TLS handshake, Newsession Ticket (4):
  • old SSL session ID is stale, removing
  • Connection state changed (MAX_CONCURRENT_STREAMS == 256)!
    < HTTP/2 200
    HTTP/2 200
    < date: Sat, 19 Jun 2021 10:02:01 GMT
    date: Sat, 19 Jun 2021 10:02:01 GMT
    < content-type: image/png
    content-type: image/png
    < content-length: 2425
    content-length: 2425
    < access-control-allow-credentials: true
    access-control-allow-credentials: true
    < cache-control: public, max-age=2678400
    cache-control: public, max-age=2678400
    < cf-bgj: imgq:85,h2pri
    cf-bgj: imgq:85,h2pri
    < cf-polished: origSize=2612, status=vary_header_present
    cf-polished: origSize=2612, status=vary_header_present
    < etag: W/“a34-17a1b639930”
    etag: W/“a34-17a1b639930”
    < expect-ct: max-age=0
    expect-ct: max-age=0
    < last-modified: Thu, 17 Jun 2021 19:12:30 GMT
    last-modified: Thu, 17 Jun 2021 19:12:30 GMT
    < strict-transport-security: max-age=15552000; includeSubDomains
    strict-transport-security: max-age=15552000; includeSubDomains
    < vary: Origin
    vary: Origin
    < x-content-type-options: nosniff
    x-content-type-options: nosniff
    < x-dns-prefetch-control: off
    x-dns-prefetch-control: off
    < x-download-options: noopen
    x-download-options: noopen
    < x-frame-options: SAMEORIGIN
    x-frame-options: SAMEORIGIN
    < x-xss-protection: 0
    x-xss-protection: 0
    < cf-cache-status: HIT
    cf-cache-status: HIT
    < accept-ranges: bytes
    accept-ranges: bytes
    < cf-request-id: 0ac5516c9b000016241213f000000001
    cf-request-id: 0ac5516c9b000016241213f000000001
    < report-to: {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report/v2?s=HbSgz5wJThQPDguaO%2FO19HTLcJK%2BYuL%2BLwLFCZISDNWoRnzIk06Y2HC218rj9Wa9gauPBaFdROp%2F%2Be1tHMWajN%2BwNFHciItr9XXHhkk5QI2SDBCIUld%2B"}],“group”:“cf-nel”,"max_age”:604800}
    report-to: {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report/v2?s=HbSgz5wJThQPDguaO%2FO19HTLcJK%2BYuL%2BLwLFCZISDNWoRnzIk06Y2HC218rj9Wa9gauPBaFdROp%2F%2Be1tHMWajN%2BwNFHciItr9XXHhkk5QI2SDBCIUld%2B"}],“group”:“cf-nel”,"max_age”:604800}
    < nel: {“report_to”:“cf-nel”,“max_age”:604800}
    nel: {“report_to”:“cf-nel”,“max_age”:604800}
    < server: cloudflare
    server: cloudflare
    < cf-ray: 661beb5a98a91624-WAW
    cf-ray: 661beb5a98a91624-WAW
    < alt-svc: h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400, h3=":443"; ma=86400
    alt-svc: h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400, h3=":443"; ma=86400

<
Warning: Binary output can mess up your terminal. Use “–output -” to tell
Warning: curl to output it to your terminal anyway, or consider "–output
Warning: " to save to a file.

  • Failed writing body (0 != 588)
  • stopped the pause stream!
  • Connection #0 to host sigbtc.pro left intact

Regrds,
Miroslaw Pabian

Do note that setting the edge cache to a month, doesn’t guarantee the resource to stay there one month.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.