I need http and https both working

hello, i can’t edit cloudflare configuration for my site http://seasib.com working and both modes http and https, but cloudflare always redirect to https protocol, Flexible mode now enable and Always Use HTTPS is off and HSTS is disable, how fix it?

Do you have a page rule set up that redirects to HTTPS or something configured on your web server that initiates the redirect?

no, my server working only on http protocol

also i have 2 page rule, but when i turn off it still http dont work

Could you share the page rules? Also, did you check your .htaccess and/or server config for any redirects?

If you’ve enabled “Always Use HTTPS” in SSL/TLS -> Edge Certificates, then you can’t use HTTP.

i told my server working just http(https not available), rule page enable http for define page and GET parametrs

“Always Use HTTPS” is disable

1 Like

anybody can help me?

It might be that your web server or code redirects users to HTTPS. If you’ve disabled “Always HTTPS”, don’t have any page rules redirecting to HTTPS, HSTS disabled, and no apps that might redirect you, then Cloudflare will not redirect users. Therefore it has something to do with your server configuration.

1 Like

i think this occuring because cloudflare dont change request headers for cached page, for example you can see that page http://seasib.ru/nnpage/ working without https

I guess it’s your application that’s doing the redirect, as non Apache error pages are redirecting to HTTPS.

1 Like

you understanding that all working good on native ip without cloudflare?

Then I’d recommend contacting Cloudflare support. It seems very odd to me, that the redirect is not happening on Apache pages but just on pages with your application. Cloudflare would redirect all HTTP, if “always use HTTPS” is enabled. Maybe your application or web host checks if HTTPS is available, and if so, redirects you.

Here are possible reasons why Cloudflare might redirect you to HTTPS - maybe that helps:

  • Always use HTTPS enabled
  • A page rule was created that does that
  • The application or origin server does it, which means that it is not related to Cloudflare

This topic was automatically closed after 30 days. New replies are no longer allowed.