I keep getting an error whenever I try to purchase a domain

I have tried putting my order in for a domain more then 15 time over the last 2 days and it’s not working it keeps saying there was an error and I received an email from Cloudflare to say it was unsuccessful and try again later and I have done so and it has not fixed it can you please tell me why asap as my company has now been delayed it’s date of launch for the past 2 days because of this error if you could help me asap that would be greatly appreciated.
thank you,
Kind regards zapped phone repairs

Hi @zappediphonerepairs,
Please visit our Support Portal at https://dash.cloudflare.com/?to=/:account/support , where you will have access to self-help resources tailored to your issue. Please remember to choose the relevant category (e.g. Billing, Account, or Registrar). If those guides don’t solve your problem, you can submit a ticket, and our team will address it as soon as possible.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.