I haven't been able to create a single name server and i have been trying for a month

I recently bought my domain from google domains and have followed through every step correctly but nothing is happening. In my dns records it says “Cloudflare protection for your domain is in a pending state while we verify ownership. This could take up to 24 hours to complete,” but still nothing is happening. What can i do?

What the the domain name?

2 Likes

What exact steps are you taking to “create” this nameserver? Where & what error are you seeing?

Contact your domain registrar, namecheap, and ask them to change the nameservers currently assigned to your domain from their two to only the two shown on https://dash.cloudflare.com/?to=/:account/:zone/dns.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

So I have followed multiple mainstream instructions. Yet cloudlfare is still in a pending state looking for my nameserver. As for my dns records, cloudlfare is having trouble verifying ownership and it has been like that for a while now.
What could be the problem?

What is the domain name?

1 Like

I bought my domain from google domains a few month ago. I’ve followed diffrent types of mainstream tutorials and none of them seem to help. When changing to custom nameservers cloudflare can’t seem to verify me or make any progress to do so. I contacted google support but they just sent me link on how to change manage nameservers, steps i’ve done. I’m very sure i haven’t missed any big step and was wondering what i could do?

What is the domain?

1 Like

Do you mean google domains? I’m pretty new to this.

I mean, what is the domain name you have registered? If you are adding the site to Cloudflare and it isn’t verifying, we can look and see why that may be.

2 Likes

refinedconnections.net | DNSViz

You need to update your DNSSEC.

2 Likes

in short - so all i’ll have to do is enable dnssec from the link?

DNSSEC is now disabled at your registrar so at the moment your domain is waiting for verification in Cloudflare. Don’t re-enable DNSSEC until the site is verified.
https://cf.sjr.org.uk/tools/check?6aeec2474da44b9ea95e49f4e3053114

If verification persists for another few hours (in case you just made a change), make sure…

  • the Cloudflare nameservers you set at your registrar are those for your domain. If you have deleted and added the domain to Cloudflare the nameservers will have changed so check that they are aisha and garrett shown at the bottom of this page in your dashboard…
    https://dash.cloudflare.com/?to=/:account/:zone/dns

  • check you haven’t misspelt your domain name when adding to Cloudflare (seems obvious, but happens more often than you think)

  • add an A, CNAME or others records to the DNS (this isn’t actually needed, but just in case it helps create the zone)

  • if all else fails, sometimes the process seems to get stuck and deleting the site from Cloudflare and adding it back again makes it work - note that this will give you a new pair of nameservers so you will need to update the nameservers at your registrar again.

2 Likes

I payed for my domain through google domain, and cloudflare can’t verify ownership. I have contacted both help from here and my registrar. The help i got here that didn’t work:


The help i got form my registrar was pretty useless, they just told me to follow the basic steps that didn’t work. What can i do now? I followed the advices given to why it wouldn’t work and none of them worked for me, i tried removing my site and adding it, although i didn’t get any new nameservers.

Hi Yassin,

Just to confirm are we talking about the domain refinedconnections.net ?

Have you followed this guide on adding a zone to Cloudflare? - Add a site · Getting started · Learning paths

When I query your domain I’m not seeing any DNS records resolving for your domain:

refinedconnections.net.	172800	IN	NS	aisha.ns.cloudflare.com.
refinedconnections.net.	172800	IN	NS	garrett.ns.cloudflare.com.
;; Received 110 bytes from 192.12.94.30#53(e.gtld-servers.net) in 40 ms

;; Received 57 bytes from 162.159.38.186#53(aisha.ns.cloudflare.com) in 27 ms

This makes me think either you have not added the zone to Cloudflare, or you have not configured your DNS records correctly, or you are using the wrong nameservers that are not assigned to your zone.

Following the guide above and ensuring you have configured the correct nameservers (assigned to your zone by Cloudflare) at your registrar (google domains) and making sure your DNS records are configured correctly is the first step here.

regards,

2 Likes

@yassin I reopened this topic & merged your multiple duplicate topics into one.

There have been a lot of replies and suggestions.

Please reply to:

  • What is the name of the website?
  • In looking at your account I see websites deleted, pending & purged; that’s why the information above is needed.
1 Like

Are you talking about my site

I will try my best to provide any information needed, should i send i screenshot of my dns records?

You could try to answer the question:

The answer should be something like example.com.

A screenshot of your DNS records for that domain would also be very helpful. Make sure it includes the assigned nameservers that are right below the DNS records.

2 Likes