I have tried to add a

I have tried to add a subdomain, but it is still not showing up when I visit the subdomain. I have cleared my local DNS cache.

I have added the CNAME to the DNS records on cloudflare. How long should it take to work?

Welcome to the Cloudflare Community. :logodrop:

DNS changes in Cloudflare are often visible immediately.

What do you mean by:

Does this mean that you are testing by trying to load a site using the name in your web browser? What error appears? Does your web server know that it is supposed to answer to the alias you created with the CNAME?

Thank you for your response.

Yes, when I input staging . mysite. com I get “DNS_PROBE_FINISHED_NXDOMAIN” error. Yes, the web server has the subdomain setup and supported (if that is what you mean).

If you can share the domain name and the hostname that you are having trouble with, the Community can share what they see.

The host is jacobsenhomes .net and the domain I am having trouble with is staging . jacobsenhomes . net

Your domain is not using Cloudflare DNS, so no changes in your Cloudflare account will have any effect.


You can follow this Community Tutorial to finish activating your site on Cloudflare.


Interesting… the DNS records in my domain provider (godaddy) reference cloudflare. Maybe it still needs to propagate to global DNS… I’ll do some more digging. Thank you for your help!

OMG facepalm I just double checked my name servers on GD and they were exactly what you posted. sigh.

Thank you again for all your help. I truly appreciate you dealing my total lack basic research.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.