I have the 522 error in the websit

Dear Community and Support center,

I have the 522 Time Out error in the website. As per the suggestion i increased the server capacity, checked Http request Keepalive as well all are working well. But still receiving this error in the site. BTW, i am using GCP as webhosting provider and i contacted them they said the error is from CloudFlare end.

Website: https://www.absoluteracing.net/

Let me know, thanks in advance

You may refer to this first:

2 Likes

I have read it whitlisted the IPs provided by cloudflare. But still getting the error

Try set the SSL encryption mode to Full (strict).

You mean in CloudFlare?

Yes.

1 Like

Hi

i did that still not fixed and showing 522 error.

I get the 522 error as well

Error 522: connection timed out

Error 522 occurs when Cloudflare times out contacting the origin web server. Two different timeouts cause HTTP error 522 depending on when they occur between Cloudflare and the origin web server:

  1. Before a connection is established, the origin web server does not return a SYN+ACK to Cloudflare within 15 seconds of Cloudflare sending a SYN.
  2. After a connection is established, the origin web server doesn’t acknowledge (ACK) Cloudflare’s resource request within 90 seconds.

An HTTP 524 error occurs if the origin web server acknowledges ( ACK ) the resource request after the connection has been established, but does not send a timely response.

Resolution

Contact your hosting provider to check the following common causes at your origin web server:

  • (Most common cause) Cloudflare IP addresses are rate limited or blocked in .htaccess, iptables, or firewalls. Confirm your hosting provider allows Cloudflare IP addresses.
  • An overloaded or offline origin web server drops incoming requests.
  • Keepalives are disabled at the origin web server.
  • The origin IP address in your Cloudflare DNS app does not match the IP address currently provisioned to your origin web server by your hosting provider.
  • Packets were dropped at your origin web server.

If you are using Cloudflare Pages, verify that you have a custom domain set up and that your CNAME record is pointed to your custom Pages domain. Instructions on how to set up a custom Pages domain can be found here.

If none of the above leads to a resolution, request the following information from your hosting provider or site administrator before contacting Cloudflare support:

  • An MTR or traceroute from your origin web server to a Cloudflare IP address that most commonly connected to your origin web server before the issue occurred. Identify a connecting Cloudflare IP recorded in the origin web server logs.
  • Details from the hosting provider’s investigation such as pertinent logs or conversations with the hosting provider.

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

1 Like

@sdayman

Alright, i will try it out and see what happens.

Okay, have you solved it?

Did the steps I provided fix the issue?

i am asking you? how did you solve your 522 error?

I’ve never experienced a 522 error (on a website I own) but how to fix it depends on the situation (there might be a different cause which requires a different solution).

@AppleSlayer i did all the steps provided by Cloudflare but none of them worked

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.