I have set MX records but the emails are not going through

Answer these questions to help the Community help you get started.

What is the domain name?
jenveyhouse.co.za

Have you searched for an answer?
Yes

Please share your search results url:
dashnex support

community.cloudflare.com/When you tested your domain, what were the results?

Describe the issue you are having:
The email hosting service provider issued the MX records I placed in CF, but the mails are not getting through.

What error message or number are you receiving?*
The server rejected one of the recipient addresses. The message has been placed in your Outbox

What steps have you taken to resolve the issue?

  1. Contacted the email host service provider for the records and they offered remote assistance to setup
  2. Changed MX records based on the attached video url.
  3. Further consulted the website host.

Was the site working with SSL prior to adding it to Cloudflare?*
Yes

What are the steps to reproduce the error:

  1. Note sure

Have you tried from another browser and/or incognito mode?
Yes

I need somebody to help and look at my records.

mail.jenveyhouse.co.za is not open on port 25. Port 587 and 465 are ok. Correction, just tried from another IP address, port 25 is open to that.

Anyway, it’s an issue at your hosting end, your Cloudflare settings are ok.

Hi Sjr
Thank you for reaching out and providing assistance. Are you saying my records are okay? What should I be telling them?

The records are ok and the mail server is accepting connections so mail should come in.

Re-reading your post you say “the server rejected one of the recipient addresses. The message has been placed in your Outbox” - are you trying to send email from your client using this mail server? If so you will need to authenticate (and likely use port 587 with SSL).

Thank a million sjr, the emails are coming through. Much appreciated.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.