I have problem with ssl please help

my website is not responing with https but i can connect with http how can i fix it.

May I ask what is your domain name?
What error do you get?

Regarding SSL issues, try with troubleshooting using suggestions from below article:

To find out more how to setup SSL for your domain while using Cloudflare, kindly see below article:

https://unii.co.th

i get Can’t access this website

Have you tried running with a lower SSL level on cloud-flare (non-strict)?

I’d check on a flexible mode, and keep HTTP Strict Transport Security (HSTS) off.
If still an issue, you’re not properly setup maybe via forwarding of server or settings. Would not be a CF issue then in my mind.

Have you as well tried using the SSL they offered and updating all your sites with it?

The encryption mode should always be “Full strict”. Please do not make recommendations which make sites less secure.

Well, no we don’t want this set to flexible unless we’re sorting or ensuring our setup. End- or final game we want 100% secured and on for settings HSTS included.

But if you want to be specific it depends on your transport and what you intend to share through the pipe. It may not matter for some hosts rather than others but goal is to sort your SSL and step-treat it if stuck but return it to fully secured or if advanced to settings you know work and won’t affect you. :slight_smile:

You either have a secure setup or you don’t. If you want your site to be properly encrypted and secure you need to have “Full strict”. Everything else is not secure.

I think you’re confused, though this is free-support so feel-free.

The user is setting up SSL and requires it. Given.
Security 100% assumed,

They’re setting it up though, so we need to know why it’s failing and at which points. I’d recommend not confusing users. Goal is to keep secured but know why it’s failing in this case.

You are new to the forum and I’d like to invite you to use the search as that topic has been discussed a million times.

Please do not confuse other users of this forum by suggesting encryption modes which are not secure. That’s all.

how can i fix it

Your issue is not Cloudflare related. Your server has no SSL configuration whatsoever, you need to fix that first. But @fritexvz already mentioned that in his first link.

1 Like

i check every thing in first link but it not work
how can i re-register domain ?

Again, you don’t need to register anything, you need to follow the advice given by @fritexvz and what I just wrote.

1 Like

i already done every but it not work

Why does your server not respond for HTTPS then?

sitemeer.com/#https://unii.co.th

Ssl was gone, previously i use for almost a year. What is the cause ?

I can confirm there’s an issue at the server that Cloudflare can not fix. You need to fix this at your host:

curl: (7) Failed to connect to unii.co.th port 443: Connection refused

3 Likes

i’m contact to my cloud server already. He said that there was no problem with the network. i can ping my ip server. Please tell me what part of the server is there a problem


i’m already complete my setup but Domain Registration is unknown what a mistake