I have issues setting up my domain


#1

Hello,i have some problems with setting up my domain.
If i add my domain and set it up it works for 15 minutes, after that i get an 502 Error… I only want to hide my server IP. i dont need caching and everything… i want to use cloudflare only for hiding my server IP.

Iam hosting my server at Vultr and NameCheap as my domain registrar.

(Sorry if i’m in the wrong category. i’m a rookie if it comes to cloudflare.)

Regards


#2

Now i also get this error. Server is up and running


#3

What is your TLS mode in Cloudflare and do you have a valid TLS certificate installed on your server, respectively TLS (HTTPS) enabled at all?

You wrote “15 minutes”, issuing the Cloudflare certificate can take up to 24 hours.


#4

i dont need a certificate in my case, i only want to hide my server IP.
Thanks for responding


#5

You need a certificate for TLS or do you not want to use an encrypted connection? In that case set TLS mode to “Off”.


#6



Its all off


#7

And still not working? Can you post the URL?


#8

500 errors are your origin server not letting Cloudflare connect to it. If you :grey: the DNS entry here, does it work?


#10

Alright, it still reports 521 but that would really indicate an issue with the origin server. Are you sure it is up and reachable for Cloudflare?


#11

The server is up and fully running. i can connect to it if i use the bare IP


#12

Any firewall settings that could prevent Cloudflare?


#13

i never looked at the firewall settings tho. there is no firewall


#14

Hmm, in that case it is difficult to tell at this point as I cant check your origin server. 521 would indicate Cloudflare cant connect, if you say it accessible that should not be the problem though. I am afraid I cant provide more feedback with the available information. You could certainly post the IP and then delete that posting (will be deleted after 60 minutes), but that would still potentially leak the IP :slight_smile:


#16

Hmm, custom port :slight_smile: … let me check


#18

Well, that wont work because Cloudflare is not working on port 30000 and AFAIK Cloudflare does not support redirecting the port, right @sdayman? That could explain why it wouldnt work. Can you change it to 80?


#19

well thats kinda weird, because it worked when i firstly added my domain to cloudflare and set the nameservers. it worked like a charm for 15 minutes. then i started to get those errors.

i could test it out tho.


#20

Was it before you activated the proxy? In that case it would have still gone directly to your machine and you could use any port you wanted.


#22

Could it be the browser was still caching the old address? Just guessing at this point.


#24

Cloudflare doesn’t redirect ports…UNLESS you’re using Spectrum. So @sandro’s link to the Port List article is correct.

Just to confirm, there’s nothing listening on Port 80 or 443?


#25

Thanks, so yes, port 30000 would not work. Can you either set it to 80 or configure a local redirect via iptables?