I have 'degraded status' when using WARP with Zero Trust

Hello good day,

I have a tunnel connected to my local computer to simulate as if it were production to see that everything works correctly, in this same computer I have installed the WARP service with Zero Trust to my organization, when I am connected to WARP the tunnel status is set to “degraded”, I read about this that some time ago was a temporary error by Cloudflare and it was already solved, but it still happens to me, is it normal or I have to do something?

Thank you and happy christmas holidays.

1 Like

Hey @manelcluaa!

I, too, have been experiencing this issue on my Mac when using tunnels over ZT WARP. From my testing it appears specific datacenters are inaccessible. I am entering my own issues in as a service ticket and will update you as I know more or if additional information is required.

Best,
Sean Mitchell

1 Like

Hello @smitchell,

Thank you very much, I am waiting for you, any additional information please do not hesitate to ask me.

Good day,
Manel Clúa

Same issue any update please !!!

@matallah @manelcluaa

Hi,

The customer service ticket I created was not associated with a business/enterprise contract, and since it’s primary use case is for us developers it wasn’t urgent enough for me to push for it to receive attention on the weekend. I will however make sure that some movement comes today now that all teams are back. :slight_smile:

Thank you for the patience!

Best,
Sean Mitchell

1 Like

Quick update, I have learned this appears to be a known issue and am looking to see what else can be done regarding this report. It seems to be related with WARP’s routing modifications.

The support request has been merged into an ongoing conversation and I have entered a vote on our behalf for resolution. I will keep monitoring the conversation and will notify you of changes or solutions that come from it.

Thanks! :slight_smile:

1 Like

I am experiencing the same but with a cloudflared deployment in kubernetes, everything seems to be working fine, however I am getting (degraded) state as it is shown in the image below.


y

@cgutierrez is your K8 system behind a client on WARP?

No, it is actually running on a separate dedicated pc with minikube installed

I have reached out to you in a private chat requesting logs. Please share them with me so I can identify if your issues is in the scope of this thread.

hi guys,

Any suggestion for this issue? I try to do with warp ist on and I got a same problem.

@joninorbert

I should have an update by the end of this week (probably much sooner), and will be able to answer soon.

Hello Everyone (@here),

My apologies the wait on this has been awhile, it can take sometime to discuss large routing topics like these that have broader implications.

While considerations are currently being made about official support for “Tunnel over WARP/Gateway” becoming a feature, I would recommend the workaround of adding the Tunnel IPs to your client’s split tunnel. To get a list of our Tunnel IPs, please follow this documentation:

Let me know if there is anything else I can help with, otherwise this will close out automatically in the coming days.

1 Like

Hello,

Sorry for not answering these days, between work and commitments I have been busy, I will mark your answer as solved and follow the guide indicated.

Thank you very much for your help,
Manel Clúa

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.