I have been waiting for the certificate to be verified for 2 days, my website is still not working

Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?

Please share your search results url:

When you tested your domain, what were the results?

Describe the issue you are having:

What error message or number are you receiving?

What steps have you taken to resolve the issue?

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. In Overview set Flexible
    2.SSL => Edge Certificates => Status: Pending Validation (txt)

Have you tried from another browser and/or incognito mode?

Please attach a screenshot of the error:

Welcome to the Cloudflare Community!

What is your domain name?

Unrelated to the error, but this should always be Full (Strict)

1 Like

What is your domain name? tongetrip.pl

Your DNSSEC Configuration is broken.

; EDE: 9 (DNSKEY Missing): (no SEP matching the DS found for tongetrip.pl.)

https://dnsviz.net/d/tongetrip.pl/dnssec/

It looks like you set up DNSSEC at your Registrar, home.pl, for a prior DNS Host. You do not have it enabled on Cloudflare.

You’ll want to either outright disable DNSSEC, or enable DNSSEC At Cloudflare and update your DNSSEC configuration with the information Cloudflare gives you:

These changes to your DNSSEC Configuration can be done at your Registrar, home.pl.

Once you fix DNSSEC, you’ll have to give it a bit to propagate for DNS to start resolving again. Then you can disable Universal SSL (under Edge Certificates, the same tab as you found it pending before) and wait ~5-10 minutes and re-enable, and Cloudflare would retry issuing. Otherwise you could wait it out, but it may take a bit longer as Cloudflare backs off retrying issuing the cert the longer it fails for: Validation backoff schedule · Cloudflare SSL/TLS docs

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.