I have an exclamation mark on my website padlock

I had a stroke and lost my memory. I got the ssl to work on my website. The padlock is closed, but I have an exclamation mark on the padlock. I went through all the code and changed the lines to https but I still can’t get rid of the mark. Can someone help me as it sucks without a memory.

1 Like

What’s your encryption mode on Cloudflare?

Thank you for replying. It is on full. This is so difficult for me not having any memory.

In that case

My website is not for people to come to. I basicly have it to remember websites, Dr. visits with phone numbers, what medications I take. So it is just personal.

I read your reply, but with no memory what so ever, I’m not understanding what you mean. Before the stroke, I had this setup, and I did do it with no help. I don’t remember why things changed. :confounded:

Now I’m getting Error 526

Ray ID: 671b6531ac5b3107 • 2021-07-20 10:09:40 UTC

Invalid SSL certificate

Hi @user2674,

A couple of questions. Do you have a server/VPS that you’re hosting it on or are you using a shared hosting service?

Is the site something you’ve written from scratch or are you using something like WordPress?

For your site to be secure, you need your SSL/TLS mode to be Full (Strict) as @sandro said, but for that you will need a valid certificate on your server or with your host.

I suspect the exclamation mark you are seeing says that some parts of the site are insecure? If that’s the case, it’s probably mixed content, you could use developer tools (F12 in most browsers) and look at the console to see where the problem is.

1 Like

From scratch. I have GoDaddy… as far as I know it is not a shared hosting service

The exclamation point went away now I have a / over the padlock

If you want to stick with the secure Full (Strict) and need to fix the 526, you may want to look at Cloudflare Origin Certificates and whether you can use one on your server.

https://developers.cloudflare.com/ssl/origin-configuration/origin-ca

Can you post a screenshot of the padlock symbol and what message you see when you click on it?

1 Like

1 Like

So I guess that is the site, what about the padlock that has the warning/symbol?

I don’t know how to add that I click on take screenshot full page but it didn’t capture the address bar.

Oh, I see.what OS are you on? Windows, Mac, Linux?

1 Like

windows

You should either be able to use the PrtScn button on your keyboard to take a shot of the whole screen, or something like Snipping Tool to take a section.

1 Like

Hi user,

If i understand correcly https is just working fine in your website right?
The exclamatiin mark can be because of any kind of resource loaded over http:// instead of https. (Images, videos, documents,… included) Check your source code for any resource inclusion over http, try to change it to https if that doesn’t work remove the resource inclusion and i think the exclamation mark should go away.

Cheers

I’d like to add that this would apply on every seperate html page. They should be totally http free sort of speak. A correct server configuration sometimes not enough. Be sure to check the source code from your browser after some possible javascript did jobs to be absolutely sure!

Thank you so very much… only about 3-4 pages of my website has been changed over and I checked the source code on the pages that I use. I will try your advice just as soon as I figure out what is wrong with me. Not sure if I had another stoke or not, but I can’t even hang on to glasses. Broke 3 today in a really short period of time, harder that ■■■■ to type, and that’s not me. So I thank you again, I’m sure that is my problem now, as I only did that on the frequently used pages… From what I can see, only 33% of my website is unsecured. I really can’t say thank you enough.

2 Likes