I have active my SSL for my website but still not live. please help

I have active my SSL for my website but still not live. please help

http://www.themiceco.com/

You have “too many redirects”. Check your SSL/TLS setting is set to “Full (strict)” in your dashboard here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.