I have a problem with ssl

my thoughts:

chrome -> https -> cloudflare -> nginx -> http

problem:

image

Description

1、It is normal when cloudflare is not used

chrome -> https  -> nginx -> http

2、SSL/TLS encryption mode is
Full

Hi,

Full SSL/TLS will only work if you have HTTPS enabled on your origin. So that is very likely the reason why you are getting that error.

You can check out more info on setting up SSL/TLS here:

Hello, the ssl of my website is normal.

According to the tutorial, I should use Full (strict)

That is the recommendation.

Do you mind sharing your domain please?

The IP you have in the error message isn’t from Cloudflare (IPs).
I would recommend you double check the IPs you have on your DNS configuration, making sure your domain/subdomain is pointing to the right one. Also, make sure your website works properly over HTTPS before enabling SSL/TLS and setting the domain to :orange:.

That error message says you’re trying to connect to an IP address. Not a hostname. Cloudflare only responds to requests for your domain name.

2 Likes

Thank you very much, please help
https://show.liyang.site/

The ip in the message is the LAN ip of my machine.
Equivalent to 127.0.0.1, which is proxy_pass set in nginx

This can work
I set it directly in /etc/hosts

xx.xx.xx.xx show.liyang.site

Thank you for your reply.
I use nginx forwarding

I see. Your subdomain redirects to 172.17.0.13. And as you said, it’s a private IP address. This is not under Cloudflare’s control.

1 Like

Is this situation not supported?
https://xxx.com -> cloudflare -> ip (public network) -> nginx -> ip (local) -> sever

It sure is! Browsers can connect to your subdomain through Cloudflare:

1 Like

But there is a problem, and it cannot jump correctly.

If you add this to your /etc/hosts, it is the correct effect

xx.x.x.x show.liyang.site

Yes, that does work. Interesting. Something at the server is replacing the hostname.

How about this? Add a Page Rule to do the redirect:
Match: show.liyang.site
Setting: Forwarding URL (302) https://show.liyang.site/login?next=http%3A%2F%2F172.17.0.13%3A5080%2F

1 Like

Thanks, i try

1 Like

This can work. thank you very much.

Is there any other solution besides this?

Other than figuring out why your server replaces the hostname in the forwarding URL, this would be it.

I thought this was the behavior of cloudflare, I understand what you mean, this is a problem with my server

1 Like

I’m having same issue with SSL.

This topic was automatically closed after 30 days. New replies are no longer allowed.