I have a caching problem and request help from the platform

Yesterday I opened cloudfare, but I visited the site this morning when the site is still several days ago, now enter the site, the content of the page is not at all the content of the server that I specified the DNS IP, or the content of the previous server, but that are several days, why would cloudfare have that inside the cache? And it has not been updated with the latest content?

The cache is already clear, and open developer mode, also does not work
my domain : moonnav dot com

Seems to me like you’re using Page Rule with Cache Level: Cache Everything which caches the HTML webpage, which by default isn’t cached as stated in the article below :thinking:

At least by what I see by looking the cache headers:

cache-control: max-age=7200
cf-cache-status: MISS
x-nginx-cache: WordPress

So, it’s cached in visitor’s (your’s too) Web browser for 2 hours, then expires.
Then Cloudflare see’s MISS, then caches it to it’s Edge for the next period and keeps it to have it HIT next time you hit refresh (F5) and for the next visitor. In short, however you’re also using some kind of a “page cache” at your origin host for WordPress.

It might end as you update the post content/page at your web server via WordPress, however this either a) might get flushed and cached at origin host/server again as “new” and b) it might be Cloudflare keeps the old version cached and presents it to the visitors for the next 2 hours and doesn’t “ask” the origin to “hey, serve me the fresh one” until that expires at Cloudflare Edge first, so it would be served as “new” to further coming visitors of your Website.

May I ask what option have you got selected for the “Browser Cache TTL” and “Edge Cache TTL” at Cloudflare dashboard → Caching → Configuration? Otherwise, in a Page Rule with “Cache Level: Cache Everything”?

Kindly, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

Useful articles:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Furthermore, you could determine if this behaviour continues (old cached version) even by using a “Pause” option at Cloudfalre as follows:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.

May I ask which WordPress plugin are you using? There was recently some incident or issue or at least two different people reported this with Super Page Cache for Cloudflare.

my website is new, I didnot use any plugin.


THanks for answer me, I donot know what should I do.
I ping my domain moonnav dot com, then it has 2 ip, is it normal?
it looks like that when I use cloudfare lastnight, then my domain points to another ip( has a server sever days before), but not my ip now which I setting in DNS of cloudfare.
For example, my domain should points to ip1 now, which server is in digitalocean. and I only setting ip1 in Cloudfare DNS panel.
but now today, I use my website, when I visit my domain, it looks that I visit another server which is in Bluehost, sever days before, I did use bluehost and cloudfare but that DNS Configuration has pass several days.

now I can not login my website because it tell my website username and password wrong, and some pages are not right.

also, I have tried another brower even with my phone, and priacy mode with Google Browser, it all were wrong.

if you can understand what I mean?
After I use Cloudflare, I guess when I visit my domain, it’s ip is not my true ip in DNS Configuration, but another ip which I set some days ago( but I have changed them some days).
I want to know if you will cache DNS? some days?

This guide should provide some clarity on the IP addresses you see when using Cloudflare as well as offer detail on what happens when you load your site while using Cloudflare.

I know it, but my problems is that after I use Cloudflare, the ip that I configue in your DNS panel is not effected, when I visit my website, I actually visit another server, but not server that my ip points to

Has your domain name been used with another online service before your current configuration?

I am wondering if you might be experiencing the effects of a Cloudflare for SaaS partner that still has your domain active in their account.

If that is the case, you may benefit from the Liberate The Hostname tool referenced in this #tutorial.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.