I guess some Javascript issue

When the website is proxied, I can’t use javascript on the site (for example, click on the top menu drop-down menu).

If you pause cloudflare on the site, do the menus work? Can you share the domain name?

Yes, when I change to “DNS only” the top menu is working fine, and also, the product pages can change the color of the items based on the selection (with proxied, both and more functions are not working properly).
Site: playwithdiamonds . com

If you :orange: that record and disable RocketLoader, does the drop down menu work as expected?

I’m not sure, I will try it right now. (the problems used to be in Chrome).
Anyway, I Disabled the RocketLoader and proxied the A record for the site.
Let’s see…

Yeah, It’s not working now, I will keep it like this for 20 min so you can see it.

In “Shop Online” should be drop down when mouse over.

Only in Chrome?

And while proxied :orange: can you try to disable Auto Minify for javascript?

I’m not sure if only in chrome but in Brave it’s fine.
As for the disable auto minify, I disable all: Javascript/CSS/HTML. Still same issue in Chrome.

1 Like

The shop online menu appears on mouse over in chrome and safari for me. Can you clear browser cache & cookies and try again?

It seams that it was this: Automatic Signed Exchanges (SXGs)