I got https but no padlock. How do I get padlock?

I just did the entire process of pointing my nameservers to Cloudflare and then activated the wordpress Cloudflare plugin. Flexible, Force https both done. After this I got https instead of http but no padlock. I also did a cleanup of my images but still no padlock. How do I get a padlock?

Most likely is that theres some theme content or other external stuff is loaded via http.

Use your browser’s dev tools to determine which ressources are not loaded via HTTPS.

Or Check your page with
https://webpagetest.org

Can you share a screenshot and details of your browser and version.

That’s not a browser issue. it’s mixed content

I tried everything that I can do for mixed content. When I inspect element, I do see that there is a problem with a particular picture that I used to have up on my site. I removed it and the problem still is the same. Mixed content for the same image. As I am using Wordpress, I used Really Simple SSL, Insecure Content SSL, Search and Replace - all of these plugins. I deleted the picture from my slider and my media. Still the same problem. The pic is not even on the site now, yet the error is regarding the same pic.

Its not working on any browser - I tried everything(almost). So I dont think its a browser problem. I have https but no padlock and the error is the image showing mixed content error. I took the image down yet it still shows the same error.

Can you share the domain and a screenshot of your SSL settings please?

It did work. Sorry, I am a bit late to update you with this. The problem was that my hostings nameservers had to be not just completely deleted but the slots also removed. Basically, you should only see 2 slots for nameservers and both belonging to Cloudflare. That’s not the case with most hostings where you can just delete the nameservers from the slot.

1 Like

Hi I am also facing same issue. My hosting name server is correct but still i am not showing padlock ans site is showing insecure. I have checked individual pages also. All are HTTPS.
my site domain name is as below

You have a mixed content warning in one of your image. This one http://secureservercdn.net/160.153.137.40/bg1.690.myftpupload.com/wp-content/uploads/2019/07/cropped-onlinelogomaker-072119-1118-7485-500-189x63.jpg

Delete that image from wordpress and all other plugins where you have put it. Then put the image again. Also make sure that if you are using Elementor plugin or any similar plugin, you must make sure that the image is changed there as well.

This topic was automatically closed after 30 days. New replies are no longer allowed.