I Followed a Youtube Tutorial To Speed & Secure My Site But Now Certain Things Won't Publish!

Hi cloudflare community,

I am a bit of a newbie and need all of the assistance in the world of speed, security and optimization!

I came across two youtube video that was supposed to improve speed and security of my main site and subdomains on WP, however, I think one of the steps or maybe even a few of the steps, along the way, may have disabled the ability for my site to load up native amazon scripts to advertise, and it’s also not allowing disqus comments to show up on my site, outside of preview mode in edit. In “Preview,” during ‘edit post’ I am able to see the native ads fine after I copy and paste the code and put it in the code block underneath my article. But when I hit publish, the amazon native ads and search engine script won’t show up at the bottom of the article. This problem happens on the main domain and the subdomains. It’s frustrating and idk what to do about it.

The same above happens with disqus comments, when trying to install the plug-in on my subdomains. I’ve installed disqus over and over; one minute when I install it, I’ll go to ‘edit post’ and hit publish and disqus will load just fine, but the minute I log out of WP and go to the site on it’s own, the disqus comments section underneath the article is no longer there. It’s very frustrating. Oddly enough, disqus still works on my main domain site, but I guess it’s because I installed disqus comments long before I followed this youtuber’s tutorial. However, it seems like my subdomains are rejecting the installation or something. It’s just weird and I don’t get it.

With the youtuber from the video, he actually had two tutorials, where I installed W3 optimizer to speed up my site which you can watch here also: (Maybe that could be the source of the issue.)

But I think the source of the problem may be from part 2 of this person’s video, which I also followed step by step:

I followed part 2 of his video, step by step, and I am suspicious about the last part being the source of my issues, as I created rules under ‘Page Rules’ here on cloudflare, as you can see it, as where he began to instruct how at timestamp 9:06. All I did was follow his tutorial. I was not aware of what I was actually doing.

So let me show you what I mimicked from the video for those that didn’t have time to watch the video.

Rule 1 is:

http://*mywebsitename dot com/preview=true

Browser Integrity Check: On, Browser Cache TTL: 30 minutes, Always Online: Off, Security Level: High, Cache Level: Bypass, Disable Apps, Disable Performance

Rule 2 is:

http://mywebsitename dot com/wp-admin

Browser Integrity Check: On, Browser Cache TTL: 30 minutes, Always Online: Off, Security Level: High, Cache Level: Bypass, Disable Apps, Disable Performance

Rule 3 is:

http://mywebsitename dot com/wp-admin

Browser Integrity Check: On, Browser Cache TTL: 30 minutes, Always Online: Off, Security Level: High, Cache Level: Bypass, Disable Apps, Disable Performance

Now looking at those 3 rules created here in cloudflare, could any of those rules be the reason as to why my site is not allowing disqus comments and native ads code to load when published? Or is the source from something else I may have did in the two videos posted? Or is the problem not related to any of these videos and is something completely different?

Please help me, as I want my site and subdomains to be secure and have good load performance, which is why I followed these tutorials. But at the same time, I do not want to sacrifice certain features like disqus and native ads. Can I have security and performance without sacrificing any WP feature or plug-in like how I’ve mentioned with the ads and disqus not showing up?

Please help! Thank you all in advance!

Those rules don’t do anything to improve website performance, as they are all admin related.

What’s the URL of something that’s not working? It’s ok to publish actual domain names here so we can check.

Hi sdayman.
It’s findthishere dot com. For some strange reason, this site keeps telling me something like “new users can’t post more than two links” even though I only posted two but whatever

Findthishere is the main domain. Disqus works fine there as you can see it under every article. However, native ads script from amazon which would show about four images of a product, with a search box that I used to place under each article, doesn’t show up since I followed both of the youtuber’s videos on improving speed and performance. I think the speed and performance on findthishere.com has improved since following both tutorials but I’ve sacrificed the ability for those native ads to show up which was real important to me.

But on a subdomain such as http://isvindalesurveylegit.findthishere.com/, I’ve installed the disqus plugin and it’ll only work after I hit publish on “edit post” and will load disqus while I’m logged in as admin. The minute I log out as admin and go to the site as a regular visitor, it’s not there underneath the article, as you can see for yourself. The native ads script won’t show up there also.

Thanks in advance for any help that you can offer!

I see some console errors due to Rocket Loader. For now, I suggest you turn off Rocker Loader in the Cloudflare dashboard under Speed -> Optimization.

It’s possible W3TC (if that’s the optimizer you mentioned) is interfering, but I suggest you try disabling Rocket Loader first, and if that doesn’t work, disable W3TC also while you debug your setup.

Hi sdayman, thank you so much for the rocket loader suggestion. Since, I turned it off, I went on my site and the subdomain sites and tested the Amazon code that would bring up the native ads, and it would actually appear when published!! So that is great news! So it looks like half of the equation is solved. The other half is the only issue!

Disqus comments are still not loading on the subdomain sites when published! During the time I’m logged into WP, I have to go into edit post, I make sure the comments are turned on and I hit “Publish” and Disqus will load fine. As soon as I log out and try to visit the site as a regular visitor, it doesn’t load whatsoever. Help!! What could be the issue with that and how can I address that? Thank you so kindly in advance!

Hi, is there anyone here that can offer any assistance on this issue?? It’s still not resolved. Thank you so kindly.

I looked at the isvindalesurveylegit subdomain and it looks like you’re doing a Cache Everything. That’s generally a problem unless you’ve really worked out any issues. For now I suggest you disable a Cache Everything rule until you get this resolved.

Hi sdayman. Where do I go to disable a “cache everything” rule? Do I do that here on Cloudflare somewhere? Are you referring to the 3 rules in my OP that I set up from the video above?

In the browser cache TTL, it’s set to 30 minutes in all of my rules? Do I somehow disable that or maybe set to 0 minutes? Or are you referring to the ‘Cache level: Bypass’ rule that has been set to all 3 rules?

Anyway, just tell me how to perform the function of disabling cache everything?

And before I do anything, can you also look at another one of my subdomains and see if you find the same consistency with cache everything in order to know if the caching is indeed the root of the problem?

https://lgv30phoneunlocked.findthishere.com/

The website above also has the same issue of not being able to load discuss outside of the time that I’m logged into WP.

I need all the help I can get. Thank you so much man!

Those rules don’t align with what I’m seeing. By default, Cloudflare won’t cache HTML. Have you changed those rules, or added any others that have a Cache Level of Cache Everything?

Screen Shot 2020-02-18 at 8.10.54 AM

No, I haven’t changed or added anything. I’m still trying to figure out what you meant or where to go to even disable a “cache everything” rule.

Plus, didn’t you say earlier that those rules are only admin related? Again, I’m not even sure what those rules that I took from the video were supposed to do. I only thought it was to make my site faster and more secure but you told me they were only for admin purposes. So now I’m confused on what those rules were supposed to accomplish.

I don’t even understand the image above and what you’ve circled. What does it mean? Bare with me because I’m still sort of a newb and can get confused easily

I did say they’re admin related, which why this is such a mystery. The text I circled says the resource is cached, which Cloudflare doesn’t do by default. At this point, you should open a support ticket and include a link to this thread.

Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.