I enabled webp and purged the cache

Hi,

I enabled webp and purged the cache.

When I check the content type of the image I see image/jpeg.

The content-type should be webp not JPEG. I am on the pro account.

Any ideas why is that?

You are correct, but this will just happen if Cloudflare was able to create a smaller WebP image out of the given resource and according to your settings.
Probably you have set the settings to “Lossless” which is often the reason a smaller WebP image can not be created.

Try switching to “Lossy” and make sure you have ticked the box “WebP”, after this clear cache again, then:

  1. open Dev Console
  2. Go to network tab
  3. disable Cache
  4. hardreload
  5. check Content Type again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.