I don't understand nothing about SSL

my website is running on xampp, i tried to add an SSL to my website (so certificat in xampp), and to my server (nodejs https websockets).

On the website was working, and now is absolutely broken, i dont know why.
The domain is traittor.com

On server side i tried

        const server = createServer({
            cert: readFileSync('./crt/cert.pem'),
            key: readFileSync('./crt/key.pem')

        this.ws = new WebSocketServer({ server });

with cert.pem and key.pem distributed by cloudflare

But connection to traittor.com:8080 is absolutely not working.

If someone can help me,

Oops, is traittor.net btw instead com

After two hour i finally make works the site.

But the https websockets server https://traittor.net:8080/is still not working, but is working fine from my server can someone explain me

If i go to i have the cloudflare certificat but is not secure :frowning:

Port 8080 is not typically used for HTTPS. Cloudflare expects HTTP on port 8080.

1 Like

Thanks i tried the port 8443
but the error is still the same
and literally no answer on

Does it work as expected by hostname with Cloudflare paused?

1 Like



It doesn’t work for me. I got as far as the Cloudflare Origin CA certificate warning. Once I told it load anyway, it did nothing but eventually time out. It is doing the same through the proxy now, too, with an error 524.

1 Like

Yes I honestly don’t understand anything, I think I’ll continue tomorrow I’ve been on it for 5 hours, thank you anyway

1 Like

I just made a script with

import https from 'https';
import { readFileSync } from 'fs';
import WebSocket, { WebSocketServer } from 'ws';

const options = {
    cert: readFileSync('./crt/cert.pem'),
    key: readFileSync('./crt/key.pem')

const server = https.createServer(options, (req, res) => {
  res.end(`hello world\n`);

const wss = new WebSocketServer({ server });

wss.on('connection', function connection(socket) {


https://traittor.net:2053/ https server seems working good, but the websockets affilied no. I really dont understand.
I enabled websockets in cloudflare dashboard.


If someone can help me, i take it, i have literally no errors it’s terrible :frowning:
I wonder if the error would not come from HTTP/3 protocol or maybe of my DNS not actualised goodly yet ?

It’s fixed now, automatic i dont know why.
I think was a problem with OVH DNS.

Thanks a lot @epic.network for take time on my thread!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.