I don't receive Email

Hi,

This is a follow-up from my previous topic, I didn’t have time to reply,

I changed DNS as suggested by hanami.run, the following is the revised one,

However, it’s not working. Please help.

Please make sure you have opened all requied ports.
The DNS section seems to be correct.

What programm/software are you using to check if you received Mails?

Please also read this (related issue):

To make sure your e-mail should continue working propperly, kindly from the screenshot above:

Two ways possible to make your e-mail work:

  1. you should remove CNAME mail record.
    Then, add new A mail record with a content 112.78.125.187 and Proxy status :grey: (DNS only).
    Change the existing MX stylusdesign.co.jp content from mx1.stylusdesign.co.jp to mail.stylusdesign.co.jp.
    And in your e-mail client (Mozilla Thunderbird, Microsoft Outlook …) for POP3/SMTP use mail.stylusdesign.co.jp

  2. remove CNAME mail record.
    Rename the existing A mx1 to A mail record.
    Change the existing MX stylusdesign.co.jp content from mx1.stylusdesign.co.jp to mail.stylusdesign.co.jp.
    And in your e-mail client (Mozilla Thunderbird, Microsoft Outlook …) for POP3/SMTP use mail.stylusdesign.co.jp

To make your FTP work, you should also remove CNAME ftp record and add new A ftp record with a content 112.78.125.187 and Proxy status :grey: (DNS only).

How to edit and add an record at Cloudflare dashboard, see the steps as written here:

See more helpful information about how to make your e-mail work with Cloudflare here:

1 Like

Or just make sure your DNS records at your DNS dashboard look as like on the below screenshot :wink:

Just to note, here are two TXT records as an example - you should have only one as you have with value like you have v=spf1 a:.....

Thanks for your help. I’m not familiar with those required posts, how can I check and change the setting?

I added my yahoo account in my site Wordpress so if someone sends an Email from the site contact page, it also sends a copy to my yahoo account automatically, so then I can check the Email but there is sometime delay, can’t check it right away.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.