I could not receive email after I moved my DNS to cloudflare

I could not receive email after I moved my DNS to Cloudflare.

According to comments from Gandi, I should have the following three records in DNS,

and the final dot (.) at the end is important. If I leave this out, my record will not work.

see https://docs.gandi.net/en/domain_names/faq/record_types/mx_record.html

I noticed my two MX records in my DNS don’t have the final dot (.) at the end. I have tried to add it back manually, but Cloudflare did not save it.

Please help to handle this issue.

Thanks

You’re fine without the dot. Cloudflare will add it during lookups. Here are my DNS records for Gandi mail:

Thanks for your clarification.
I tried again but still could not make my email arrived at the email account hosted by gandi.

Do I need all these 4 records you mentioned ? Currently, I only have three records, the first two and the last one.

Thanks

sdayman via Cloudflare Community [email protected] 於 2019年8月26日 週一 下午8:47寫道:

The last two records don’t affect your receiving email for that domain. Those are for helping make sure the mail you send doesn’t get marked as spam.

What’s the domain?

Hi,

Thanks for such a quick response.

My domain is techseo.tw

Thanks

sdayman via Cloudflare Community [email protected] 於 2019年8月28日 週三 上午6:53寫道:

I’m just not seeing anything wrong with the DNS settings. Is mail bouncing back to senders? Or your mailbox is empty? No new mail showing up? How are you checking your mail (app or webmail?)

Here’s an SMTP test to watch a connection to the mail server. Just input the primary MX server and a valid email address at your domain.
https://www.wormly.com/test-smtp-server

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.