I cant receive or send email! :(

after i switched to cloudflare i cant send or receive email. i checked everything seems like okey but i just cant do it. I am new so cant deal very well, already spend 3 days between google youtube and here community support :slight_smile: :joy:
appreciate for help.

Hi @user3966,

This should help:

i have checked but couldt find any problem. i have one mx file even says this will expose you origin IP.

Looks like point 4 in the linked #Tutorials may be the issue in this case.

hello, as i understand i should take webmail to grey cloud mode right?
i did it and still cant receive or send mail.

Your MX record ports to mail.fliocal.com. Get rid of the CNAME for mail.fiyocal.com, set an A record for mail.fiyocal.com, and make sure mail.fiyocal.com is not being proxied.

I’m not sure why it’s resolving this way, it doesn’t make much sense, but FWIW, I cannot connect to a mail server at the location you’re currently pointing to. So, I’ll amend my previous instructions with one more, which is: determine the IP address of your mail server and make sure it is functional. Of course, that is sort of implied in the instructions.

$ host -t mx fiyocal.com
fiyocal.com mail is handled by 0 dc-d83d1bc437d1.fiyocal.com.
$ telnet dc-d83d1bc437d1.fiyocal.com 25

I’m also curious if anything pops up when you hover over the triangle/warning next to the MX record.

hello robert,
i just tried to did what you said and i deleted all other dns settings. but still cant receive and send. and yes warning says as attachment thanks for reply

At least from a DNS perspective, mail seems to be set up correctly now:

[[email protected] ~]$ host -t mx fiyocal.com
fiyocal.com mail is handled by 0 mail.fiyocal.com.
[[email protected] ~]$ host mail.fiyocal.com
mail.fiyocal.com has address
[[email protected] ~]$ telnet mail.fiyocal.com 25
Connected to mail.fiyocal.com.
Escape character is '^]'.
220-md-hk-8.webhostbox.net ESMTP Exim 4.92 #2 Fri, 08 May 2020 14:14:13 +0000
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
EHLO foo.bar
250-md-hk-8.webhostbox.net Hello ec2-3-213-152-5.compute-1.amazonaws.com []
250-SIZE 52428800
250 HELP

I think any other issues, such as mail configuration at your hosting company, are not within the scope of Cloudflare.

1 Like

Hello Robert,
seems like problem solved i can recieve mail and sent.
thank you very much
one more question i deleted all other record excet these 4. can be a problem or i configure them back?
thank you one more time :kissing:


thank you too for your time and advice. :kissing_smiling_eyes:

Excellent! I don’t think it should be a problem to add back the other records.

1 Like

Hello Robert,
i still get warning beside a record or exposing ip address. is that a problem?
thank you i will do soon.

It’s certainly not a technical issue. It could be viewed as an information leak, if that makes sense, but it won’t affect operation.

1 Like

got it. thank you very very much…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.