I can't get redirect Page Rule to work for broken link

Greetings everyone.

I began ranking on Google on a page on my domain with a permalink that has been changed which leads to a 404 error when the link is klicked on Google.

I would like to redirect it but I can’t seem to get it to work.

Here is what I’ve done:
If the url matches: https://sprakutbildning.com/spansktalande-lander-i-varlden-komplett-lista/

Forwarding URL - 301 redirect
Forward to: Spansktalande Länder i Världen - Komplett lista | Språkutbildning

What am I doing wrong? Thanks.

Works for me.

$ curl -I https://sprakutbildning.com/spansktalande-lander-i-varlden-komplett-lista/
HTTP/1.1 301 Moved Permanently
Location: https://sprakutbildning.com/spansktalande-lander/

Are you sure you are connecting via the proxies?

Works for me too now. Does it take time for the changes to take effect? :slight_smile:

Page Rules make tay ~60 seconds to apply globally (but usually a lot less). You may have also had a local cache

Page rules usually work more or less instantly, possibly a few seconds delay. You either had a DNS propagation issue or checked it the moment after adding it.

I have local cache switched on. WP Rocket. Could that have been the issue? Thanks.

Any caching on your server does not play a role here, that’s only client-side.

I checked it 5 or 10 minutes after adding the rule. It must have been the local cache then. Right? However, I’m happy its working now.

Most likely.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.