I cant delete a list

What is the name of the domain?

surdelsurcom

What is the issue you’re encountering

Manage Account>Configurations>Lists

What steps have you taken to resolve the issue?

I need to delete the list (Manage Account>Configurations>Lists) to upload a new one with different IPs to allowlist.
This is an old known issue but maybe there is a solution now.
I tried to delete the list, several times on different days
I tried also with a command in the terminal window but it didn’t work.
I have to delete more than 4500 IPs in the list so manual is not an option
Thanks

Was the site working with SSL prior to adding it to Cloudflare?

Yes

What is the current SSL/TLS setting?

Full (strict)

What is the error you are seeing when you try to delete the list? Could you please provide the fulll screenshot of the error you are seeing?

It says that I am using the list in the WAF, but I deleted this from the WAFs
Captura

To delete the bulk list you might want to try using an API

For the error prompt that you get, you might want to check if your rule still exist and delete it

Thanks for the answer.

  1. As I am the only user can I use Global API Key instead of API_TOKEN? There is no API token template for this purpose, I can’t figure out what settings to use.
  2. I can’t find a {ruleset_id}, as a free user I have only one rule

Sorry, this doesn’t seem very easy for deleting a list.