I cant add new member / Error 1005


I cant add a new memeber and give him “super administrator”.

“Error when processing member: cannot add existing user that is participating in an incompatible authorization system (Code: 1005)”


Are you following this procedure to change super administrator?

Is one of the accounts using Apple ID for authentication?

@epic.network Yes i did everything in the procedure. I tried to add the new member as “super administrator” and “administrator” with the same error.

No not using Apple ID, it’s a normal login (gmail).

You are attempting to replace the existing super administrator, not add another, right? Only an enterprise account can have more than one super administrator.

1 Like

@epic.network I’m trying to add an other CF member as administrator.

I tried several CF account.

Image 1 : Works
Image 2 : Error 1005…

I don’t know why it gave me different process (All accounts are free plan).

Image 1 :

Image 2 :

Same problem here with free accounts. Seems like we shouldn’t have the enterprise access rules and that is likely contributing to the problem.

Cannot add new member error 1005 - General / Dashboard - Cloudflare Community https://community.cloudflare.com/t/cannot-add-new-member-error-1005/421516

Improved Access Control: Domain Scoped Roles are now generally available https://blog.cloudflare.com/domain-scoped-roles-ga/ says

We are doing a rollout of this functionality across all Enterprise Cloudflare accounts

Manage account access · Cloudflare Fundamentals docs https://developers.cloudflare.com/fundamentals/account-and-billing/account-setup/manage-account-members/#2K2NLky0NgEtThpHOwrgx8 indicates only enterprise account should have these features as well.

Seems like it is getting rolled out further than it should, or this is getting rolled out to everyone and the documentation is misleading.

1 Like

I’m seeing this as well… asked a customer to share access with me to their CF account… and they get this error… now I have to ask them to share their login and password with me instead :frowning:

1 Like

Same issue here, across multiple accounts that are non-enterprise accounts.

Same. Tried to add 4th user that already registered with gmail. Tried to give permission to billing and DNS edit, but it didn’t work out. Though any permission settings return this error. All other users were add the same way without failures (three weeks ago)

I’m experiencing this issue as well. On multiple non-enterprise accounts (I don’t know if this is relevant or not, but the ones not working were created in the past month).


Got the same issue here even though already follow the docs here; https://developers.cloudflare.com/fundamentals/account-and-billing/account-setup/manage-account-members/#2K2NLky0NgEtThpHOwrgx8

Almost 2 days got stuck here.

Just want to add Admin only. Not Super Admin role.


I can confirm that I’m also facing this problem.
Trying to add a new Admin to our account not Super Admin.

I’m also having an issue with the new invitation system.
Trying to add myself as an admin to my client’s account, and it’s not letting me invite.

Hi All

Error when processing member: cannot add existing user that is particapating in an incompatible authorization system(Code: 1005)

This error is seen when the user/s you are attempting to invite do not have domain scoped roles enabled on their account. So, basically:

** Users with Domain Scoped Roles enabled can ONLY manage other members also enrolled with Domain Scoped Roles.*
** Users without Domain Scoped Roles enabled can NOT manage users with Domain Scoped Roles enabled.*

In order to fix this issue, we’re planning to release (enable) this feature for all of our customers in the upcoming weeks (work in progress) which will automatically resolve the issue.

Please see our blog post for more details on Domain Scoped Roles: https://blog.cloudflare.com/rbac-for-everyone/


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Hello @ccahoon, just wanted to check if there’s any updated ETA for the fix to be rolled out? I’m currently facing the same issue where I can’t add someone (which is currently using Domain Scoped Roles) from our existing account which does not have Domain Scoped Roles enrolled.


I’m here to revisit this topic again, seems like the issue is still not yet resolved, and I cannot add one of my team members to an account until now.

1 Like

If you are having this error where you are trying to add a member to your account and can’t due to the incompatible authorisation system error and you urgently need to make the change then Support may be able to resolve this for you.

To contact the support team, please submit a new support request from your Cloudflare account directly through the Cloudflare dashboard. Visit https://dash.cloudflare.com/?to=/:account/support and choose Account as the issue type.

1 Like