I cannot receive emails

i can’t receive any mails anymore. and every time i write @ as the name for my MX Record and save it, i changes to my mail. i’m a total noob at this. is there a knight in shining armor out there that can help i’m?

i’m close to having a heart attack from the tantrums. but at least i’m getting creative with the swear words…

Hi @jonaseriksenofficial,

I would recommend changing your MX record so it points to mail.drengestua.com.

Then with the A records with the name mail, delete the one pointing to (that is a Cloudflare IP and shouldn’t be there) and click the :orange: next to the other one to turn it :grey:.

Once you’ve tried those steps, please let us know if it’s working!

More info in:

1 Like

You will need to :grey: the records for pop,smtp,imap and ftp also. None of those protocols will work in a standard Cloudflare setup.

1 Like

thank you SO f*cking much for a quick answer. it still doesn’t work. but i’m not completely sure about which you wanted me to turn grey. does this look right?

No problem, that looks OK for the MX record and the mail subdomain. As @michael said, if you use POP, IMAP and/or SMTP then you will need to :grey: those too. And, unrelated to mail, FTP.

If it still doesn’t work, can you give us some idea of how you are accessing your email? Are you logging in through your host’s webmail, or using another service to retrieve the emails from your server?

1 Like

thank you! that cleaned it up. it still doesn’t work. but i guess i’m a giant step in the right direction :slight_smile:

i’m using gmail. usually just through the safari or chrome browser on my mobile phone - if that was what you wondered about?

Are you using GSuite, or Gmail and importing your mail from your server? Looking at your domain’s DNS history, it seems you were at least using GSuite up until a month ago, at which point your MX records changed from theirs to mail.drengestua.com.

If it’s the latter, in your Gmail settings, what hostname/server do you have Gmail configured to retrieve the email from?

i think it’s just gmail. and it’s managed by drengestua.com. i’m not sure where to find out for sure, but i can’t see gsuite anywhere.

i’m not sure about where to find that either. i’ve gone through all the settings options. do you mean wether i use IMAP or POP? i’m using IMAP

If you go to Settings > Accounts in Gmail, do you have anything configured under “Check email from other accounts:”

do you see it here? maybe i need to log in on my Mac instead

Thanks, if you’re OK with trying something to narrow down the issue, can you try pausing Cloudflare on the site, waiting 5 minutes and seeing if email works then?

You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions.

This will help narrow down whether it’s directly related to Cloudflare, or whether it’s possibly a DNS issue, or something on your provider.

1 Like

okey! i paused it now :slight_smile:

1 Like

Great, give it a few minutes and see if your emails work as expected then!

i said «didn’t find the email adress». i was supposed to send a test mail without starting Cloudflare again, right?

Yes, if it still doesn’t work with Cloudflare paused, it means that it is either a DNS problem (most likely your MX record doesn’t point to the right place), or a problem on your provider’s end.

i see. how do i find the right the right DNS?

or if it’s the provider: is it Gmail or Bluehost you’re referring to?

Is Bluehost hosting your emails or is Gmail? Who do you have your accounts configured with?

i can check with their chat support. unless there’s an easy and faster way to check it?

From the Gmail page you posted earlier, it’s difficult to tell, but I suspect it’s a GSuite account.

To confirm, can you make sure you are logged in with the Google/Gmail account you use and visit this page and post a screenshot (feel free to blank out your email address which may be shown on the page)? Who is my administrator? - Google Workspace Admin Help

1 Like