I cannot receive email since I started using cloudfare


#1

Hi, I am very new to this cloudfare and since I added my website on this system, My email client will not fetch the email from my cpanel… I have looked a few post on here but still dont understand how to set this properly …

Here is a screenshot: ( I just change the mail cloud to orange )

Any help will be appreciated


#2

‘mail’ shouldn’t be a CNAME. Make it an A record just like ‘ftp’ and set it to :grey:


#3

Thanks ! I just changed it now so Let s see :slight_smile: I appreciate your help !

Just to be sure: Here is the new settings:


#4

I am still getting the same error from my email client but this might take a few hours to take effect I assume since this is dns settings… ?


#5

Is mail really hosted on the same server as your website? It looks like it is. You may have to go back to your cPanel and double-check the DNS records.

Your MX record is also a problem. That entry should probably point to mail.infos.link as well.


#6

Yes mail is hosted in the same cpanel then the website.


#7

Then my instructions should work. You need :grey: DNS host names to be able to use email. Your new “mail.infos.link” should be the proper server to use for your email client and the MX record.

It looks like you have everything all set. Is your mail working now?


#8

Its still not working … maybe I need to wait for the dns change to take effect … Man this is complicated lol


#9

Oh wait its working now Sorry :slight_smile: Man I appreciate your help !! THANKS!