I cannot enable rate limiting

I seem to be unable to get rate limiting working. I have a rate limit rule for my search page as the screenshot below:


It is shown as enabled on the rate limiting rules page as below:
{Note - I am restricted from posting more than 1 screenshot due to being new}
However, when I test it live, I am not rate limited. Also, when I look at the security logs, it states I do not have rate limiting enabled, even though the enabled switch is showing on rate limiting page.

I’ve raised a ticket for this but am waiting a reply.

How do I get it enabled and running? Is there an override or something?

You help on this is greatly appreciated.

If you are using the * in the URL as a wildcard, that doesn’t work. Remove the * and use URI path contains instead. Your 2 expressions seem to be the same as well so one can ben removed.

1 Like

Could you provide the ticket number to check on it?

Meanwhile, you can review this document for Rate Limiting rules
https://developers.cloudflare.com/waf/rate-limiting-rules/

Thank you I will try this.

My ticket is #3177789

Thank you, I’ve read this resource previously but I will look into it further, including the links within that document to try to understand it deeper. I will try the adjustment as mentioned by another community member.

Ok, I have tried that and tried various tweaks, but still cannot get it to work.

Screenshot below:

Not sure what to try next

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.