I cannot connect to my site, I get "Your connection is not private"

I did some changes in my DNS settings, and it worked okay when I first tested.

But maybe 20 mins later when I tried to access my site I couldn’t, I get a white screen with a red triangle, and it says: “Your connection is not private”

I checked the certificate beside the URL, and it now says it is invalid and I see it’s not issued to my domain.

FYI … I also have this site, on the same server and I did exact same DNS changes for this one, and it still works fine.

Any idea what might have gone wrong and how can I get back my Cloudflare certificate on my site?

It would be nice if your host provided a valid certificate for your website.

You can use Cloudflare’s “Full” (not strict) SSL mode for your site to accept the incorrect Common Name in the cert.

Except that your site isn’t currently going through Cloudflare. Your DNS entry for your website is most likely set to :grey: right now.

I need to have one A record with greyed cloud to be able to receive my email. Dunno how to make email work otherwise.

I have the same settings for a few other sites that work fine, all set with Flexible SSL!

That’s why it’s broken. :grey: means it’s not using Cloudflare. Here’s some information:

1 Like

I have had my site running on Cloudflare for quite a few years now, so it is not a new setup.

I will read the tutorial regarding the email settings, but the main problem now is how can I get the Cloudflare certificate to work on my site again. As it is now, I cannot access the site and even the emails stopped working. So I guess I need to fix the site problem and get it to work first, and then I fix the email problem. Thats the steps I was thingking to do … Problem is, I don’t have a clue now how to get back the Cloudflare certificate on my site?

This topic was automatically closed after 30 days. New replies are no longer allowed.