I cannot access w3schools.com while 1.1.1.1/1.0.0.1 active

I have been using Cloudflare DNS (1.1.1.1/1.0.0.1) on my router at home for a long time. However, for the past few months, I have not been able to access to w3schools.com. When I delete Cloudflare DNS on my router, I can access it. What do you think could be the problem? Another Turkish user has created a thread (W3schools.com cannot be resolved in 1.1.1.1 (but resolvable in 1.0.0.1)) about this problem. Is it a problem with Internet Service Providers or Cloudflare Data Center in Turkey?

https://1.1.1.1/help#eyJpc0NmIjoiWWVzIiwiaXNEb3QiOiJObyIsImlzRG9oIjoiTm8iLCJyZXNvbHZlcklwLTEuMS4xLjEiOiJZZXMiLCJyZXNvbHZlcklwLTEuMC4wLjEiOiJZZXMiLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMTExIjoiTm8iLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMDAxIjoiTm8iLCJkYXRhY2VudGVyTG9jYXRpb24iOiJJU1QiLCJpc1dhcnAiOiJObyIsImlzcE5hbWUiOiJDbG91ZGZsYXJlIiwiaXNwQXNuIjoiMTMzMzUifQ==

So many problems with Internet in Turkey… :pensive:

That domain resolves for me with the following command from MacOS Terminal:
dig @1.1.1.1 w3schools.com

Try these commands and let us know which datacenter they show:
dig +short CHAOS TXT id.server @1.1.1.1 (and also 1.0.0.1)

1 Like

I agree :confused:

When I ping the site and run the dig command you shared, the ip address of the w3schools.com site comes up, but strangely when I enter the site, I get a error that the server ip address could not be found.

> $ dig @1.1.1.1 w3schools.com                                                 
; <<>> DiG 9.10.3-P4-Ubuntu <<>> @1.1.1.1 w3schools.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38781
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;w3schools.com.			IN	A

;; ANSWER SECTION:
w3schools.com.		1858	IN	A	66.29.212.110

;; Query time: 11 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Fri May 21 16:34:21 +03 2021
;; MSG SIZE  rcvd: 58

The result is the datacenter in Istanbul.

> $ dig +short CHAOS TXT id.server @1.1.1.1                                    
"IST"

Sorry, I see the issue was with the ‘www’ subdomain. Try:
dig @1.1.1.1 www.w3schools.com

1 Like

I tried again with www;

> $ dig @1.1.1.1 www.w3schools.com

; <<>> DiG 9.10.3-P4-Ubuntu <<>> @1.1.1.1 www.w3schools.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 64460
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 16 ("..")
;; QUESTION SECTION:
;www.w3schools.com.		IN	A

;; Query time: 1243 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Fri May 21 16:50:56 +03 2021
;; MSG SIZE  rcvd: 52

Are you able to open a ticket here? If so, post the ticket # here. If not, then we can tag a staff member to look at it.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

1 Like

Thanks for your help. I opened a support ticket.

What ticket number is it?

#2164425

That number. But I’m not sure if you can access it.

https://support.cloudflare.com/hc/en-us/requests/2164425

1 Like

I can’t, but Cloudflare staff check in on tickets posted here to make sure they’re being taken care of.

1 Like

Is there any update regarding this issue? It still throws SERVFAIL in Istanbul data center.

; <<>> DiG 9.16.16 <<>> www.w3schools.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 4278
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; EDE: 22 (No Reachable Authority)
;; QUESTION SECTION:
;www.w3schools.com.             IN      A

;; Query time: 2159 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Thu May 27 18:06:27 +03 2021
;; MSG SIZE  rcvd: 52

This issue exist more than 4 months already. It could already be solved if CF would switch back to Romania instead of Istanbul. But they won’t.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.