I can not turn off caching in Cloudflare and front end issues on the website

Hello, I have a Wordpress site, and there I use a Litespeed plugin to improve performance.

But I have noticed that some of the front-end parts of the site do not work correctly. I thought that I had the problem with JS minify settings and with the Litespeed plugin.

So I created a topic in the WordPress forum to find the solution. And as a result, I have problems with the Cloudflare cache. As a solution, I have to turn off the caching on Cloudflare. I did it but it didn’t help me.

Do you have any idea what is wrong and how I can solve the issue?
Thanks

I have this error in my console: GET https://primekayak.com/wp-content/litespeed/js/b18cd996d996c0d76ca948d25f9640f0.js?ver=72f5c net::ERR_ABORTED 404.

Here is a link to the topic in WordPress to better understand about what I am writing:
https://wordpress.org/support/topic/getting-404-error-for-js-and-front-end-issues/

How about contacting the web hosting about this too? :thinking:

May I ask you to post and share your domain name in bracketed dot [.] notation here with us so we could double-check, troubleshoot and provide some feedback information regarding the HTTP cache headers at least? :thinking:

Kindly, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

Are you using some custom-made Page Rules with an option like Cache Level: Cache Everything?

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Furthermore, you could determine if this behaviour continues even by using a “Pause” option at Cloudfalre as follows:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.

Thank you fritex to your answer.

Here you have my domain [.primekayak.com].

I will contact my hosting too.

I selected “Respect Existing Headers”, purged everything and opened my site on a different web browser, but the issue still appears.

The option with a pause Cloudflare on site did not work.

Sorry, I didn’t reply to you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.