I can access my site fine, but lots of users report "This site can't provide a secure connection"

Hi, when I visit my website https://rodevs.games it loads fine for me, with an SSL, but lots of my users say they are unable to access my website and get the error “This site can’t provide a secure connection”, image below. I have read the common causes and none of them are the cause, my minimum TLS version is 1.0 and 1.3 is disabled, and I have encryption mode on full.

The weird thing about this error is that it works for me and a couple of my friends I asked, but for others it doesn’t, which makes me suspect it’s something specific to their browser/device/location.

image

Does anyone have any idea what’s going wrong here? Thanks.

Try setting the “Minimum TLS” option to the “1.2” and enable the “TLS 1.3” option?

It knows to happen in my web browser on some websites, maybe due to the “HTTPS-only” mode or due to their network connection / ISP? :thinking:

I tried accessing your URL, no error.

I read the community tips - none of them are the cause.

Thanks for your suggestion, I have enabled that in the Cloudflare settings. It’s weird because so far I’ve had 400 unique people successfully register on my website, but only around 10 people reported seeing that error, so I can’t really know if that has solved it yet. Thanks anyway, I’ll see if I get any more reports of this problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.