I bought a dedicated SSL certificated - but not working

Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?

Please share your search results url:
Search results for ‘dedicated ssl certificated not working’ - Cloudflare Community

When you tested your domain, what were the results?
The moment I posted

Describe the issue you are having:
I tried to activate a dedicated SSL certificate for my main domain (www.keydstars.com.br), but is not working.

I have little knowledge on the field, so no idea if this is misconfiguration (probably is)/

What error message or number are you receiving?

What steps have you taken to resolve the issue?

Was the site working with SSL prior to adding it to Cloudflare?

Have you tried from another browser and/or incognito mode?

Tried to access to test, but blocked as a phishing domain by my zero trust solution. What error are you seeing?

1 Like

Hello @cscharff,

This is pretty much what says. Once I access the website says is not secure and potential pishing.

Its a wordpress website hosted at namecheap (easywp.com).

I’ve no idea what to do.

Interesting. I am not seeing any problems when I visit shop.keydstars.com.br or www.shop.keydstars.com.br

I wind up at an online storefront that appears to be offering some type of athletic wear in purple.

www.keydstars.com.br is not proxied :grey: and giving an SSL Cert error (because the cert is valid for your CNAME target, not the requested hostname, which Cloudflare will accept but browsers don’t). If that’s the website you are talking about, enable proxy :orange: for it within the DNS Records Panel.


I just changed the CNAME record to proxy, however still not showing up my certificate (at www.keydstars.com.br).

What else could be?

You enabled proxy for the www subdomain? Even querying the authoritive nameserver it’s still an unproxied CNAME for me
;www.keydstars.com.br. IN A

www.keydstars.com.br. 300 IN CNAME ingress-daribow.easywp.com.

Generally DNS cache will take a bit as well


I just added “proxy” to all as shown bellow

Still not working and website is broken now haha

What’s broken about it, or what’s more broken about it now then before?
For me it loads this:

If you’re still getting the same cert. error, it’s most likely just DNS Cache.

1 Like

@Chaika i think is working now! Thanks for the big help!

1 Like

That’s the primary issue. You need to fix this first and talk to your host. Pause Cloudflare for that.