I am not able to set my DKIM

Hello, I have tried to set DKIM for my domain interconstra com:
TXT default._domainkey
v=DKIM1; k=rsa;
Rest is have copied from my CPanel and still after more than 48 hours my DKIM is not set as pr mx toolbox and Mail Tester, what is the issue?

If you are using tools to look up records using just your domain, they won’t show it as they will only show records from example.com. You will need to ask them to show records for default._domainkey.example.com.

1 Like

Seems I am getting the same result

Seems I am getting the same result

(just seen the domain in your original post).

It’s there…

dig +short default._domainkey.interconstra.com txt
"v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEArjuuTcBjWPB7WRRiQvrta7hy9QqJtrCskrX8Ijg1H0zG8mVKGVvpNXOeRSKHOonn7sdrXgwqPAnYuPTe3MaIbVgD5q+gaGJ/1Vj3YXKRidzYXSMGF0bQn7s/wVfqq4IEhRihOqPJYqjATLiTaZVGQuO5BWQNepFdq6EL7EechRjCt+mdAyn4W9/54X9/hV8Mr" "lQWOs8zC+P0d1JODvsoVcE67uAPmXuD3D4epUJub/pGM4lRY3NOyvEl4i5wvJHSLJsFPEPNV9p1NlyH0o0bwakB4XvwjSm8NM5+HnfPUlYOM/QnLt1NqQvn6wzbnUgRGxEdFVa8JNFu84JJny3rewIDAQAB;"


1 Like

So I should put in the red text instead of the current text?
Because current has been generated to me by Cpanel

Just to remind, thanks

Hello, can you please reply in regard to the above message as some clients have issues with receiving my emails and I want to solve it, thanks.

The text I pasted is your current dkim record in your DNS as you originally said you couldn’t resolve it. I don’t know if it is right or not. If it is wrong, you will need to edit it.

1 Like

Correct, and that is what I have pasted from Cpanel, so I don’t see what is causing the issue as per mail tester com my email is not signed with DKIM

You will need to check your outbound mail is adding the DKIM signature to the message.

1 Like

Ok, will do, how to check it?

Send an email from your domain to somewhere else (such as gmail) and look at the headers.

1 Like

Yep, DKIM not mentioned in headers, SPF and DMARC are. How to solve it?

You will need to enable it in your mail server. You will have to Google for that as it will vary and isn’t a Cloudflare issue.

1 Like

Ok, I will contact my server admin, let me check and will inform

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.