I am not able to receive the emails on my personal domain?

I am not able to receive the emails on my personal domain.
SENDING PART IS WORKING GOOD BUT THE RECEIVING PART IS NOT WORKING

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with receiving and/or sending e-mails while using Coudflare for your domain name.

Kindly, see below suggestions and tips for troubleshooting.

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

Furthermore, if you recently moved your domain to your Cloudflare account, I could try to troubleshoot at first sight without knowing anything other as it could be related to either:

  1. Wrongly setup e-mail related DNS records at the DNS tab of Cloudflare dashboard for your domain name
  2. Possibly missing some TXT /CNAME records (for SPF , DKIM, DMARC if so?)
  3. You are using a hostname like yourdomain.com which is :orange: (proxied) rather than the unproxied :grey: (DNS-only) like mail.yourdomain.com (possible this one not existing or is :orange: instead of being :grey:) at the DNS tab of Cloudflare dashboard, in your e-mail client for sending/receiving server (MS Outlook, Mozilla Thunderbird, etc.)

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

Otherwise, you might have to troubleshoot if the port like 110/143/993/995 and 25/465/587 is open at your hosting provider and contact hosting provider to check this for you. If they are not open, then I am afraid you may not be able to receive any emails from using that web hosting/email provider.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.