I am not able to connect to the Portainer container when I am setting up Cloudfare Tunnels. Receiving Bad gateway Error code 502 when trying to access the URL

Hello, I am trying to use Cloudfare tunnel to access nextcloud and jellyfin over the internet.

I’m using Portainer and Containers to house my application. I successful created the tunnel (i.e. I can see my container details in my tunnel - I can see the Connector ID, Origin IP in the connection)

Now when I setup my public host name with the IP and Port of my application and try ao access it, I’m receiving bad request error.

Any help resolving this is appreciated.

Below post might help you a bit:

Thanks for the information @fritex . I went through the post in detail but I was not able to find the No TLS Verify option mentioned in the post (image below). Can you let me know where this option is available?

Also, this is the error I’m seeing on the cloudflared container logs:
2023-01-12T18:51:23Z ERR Request failed error=“Unable to reach the origin service. The service may be down or it may not be responding to traffic from cloudflared: dial tcp internal ip and port : i/o timeout” connIndex=2 dest=abcdotcom

2023-01-12T19:02:38Z ERR error=“Incoming request ended abruptly: context canceled” cfRay=788825c25e3cc3d7-SEA ingressRule=0 originService=internal ip and port
2023-01-12T19:02:38Z ERR Request failed error=“Incoming request ended abruptly: context canceled” connIndex=3 dest=mydomain

@fritex, Thanks a lot for the sending the discussion across. I was able to find the “No TLS Verify” option (it was under the HTTPS dropdown) and when I selected snables and then went back to HTTP, things started to work.

Much appreciate your help.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.