I am having an issue getting the edge cert installed. It keep saying invalid with internal error

Answer these questions to help the Community help you with Security questions.

What is the domain name?
crowdcoverapp.com

Have you searched for an answer?
Yes, I have tried the turn off universal SSL reset, however that solution does not work.

Please share your search results url:
https://community.cloudflare.com/t/error-initializing-universal-edge-certificate/613022/9

When you tested your domain, what were the results?
Still getting crowdcoverapp.com uses an unsupported protocol. ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Describe the issue you are having:
I am getting a red error on my edge certificates page “Initalizing(Error)”

What error message or number are you receiving?
N/A No error number.

What steps have you taken to resolve the issue?

  1. Redo local machine SSL
  2. Follow Turn off turn on Universal SSl
  3. Reduce hardening of SSL version on Cloudflare.

Was the site working with SSL prior to adding it to Cloudflare?
Yes

What are the steps to reproduce the error:

  1. Dashboard
  2. SSL/Edge Certs
  3. See Error

Have you tried from another browser and/or incognito mode?
Yes, multiple times. Cleared DNS, etc.

Please attach a screenshot of the error: